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Using this guide

Before using this guide, become familiar with the Exinda documentation system.
m Documentation conventions on the next page
m Tips, Notes, Examples, Cautions, etc. on page 5
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Documentation conventions

These documentation conventions apply across all of the Exinda documentation sets. All instances
of the following may not appear in this documentation

Typographical conventions:

m bold - Interface element such as buttons or menus. For example: Select the Enable checkbox.

m Jjtalics - Reference to other documents. For example: Refer to the Exinda Application List. Also
used to identify in the various procedures the response the systems provide after applying an
action.

m > - Separates navigation elements. For example: Select File > Save.
m monospace text - Command line text.

m <variable>- Command line arguments.

m [x] - An optional CLI keyword or argument.

m {x} - Arequired CLI element.

| - Separates choices within an optional or required element.

Links:

All links throughout the documentation are blue. Most links refer to topics within the
documentation, but there are links that take you to web pages on the Internet. In this
documentation we differentiate between these types of links by underlining only the external links.
In the web help versions of the documentation, the links may change color to reflect the status of a
link:

m Links that have recently been visited are purple.
m If your mouse cursor hovers over a ink, it changes to magenta.
m As you click on a link, it momentarily turns red to confirm that it has been clicked.
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Tips, Notes, Examples, Cautions, etc.

Throughout this manual, the following text styles are used to highlight important information:
m Tips include hints and shortcuts. Tips are identified by a pale green background.

TIP
text

m Notes provide information that is useful at the points where they are encountered. Notes
are identified by a light blue background.

£ NOTE:
N Text

= Important notes provide information that is important at the point where they are
encountered. Important notes are identified by a light yellow background.

IMPORTANT

A Text

m Cautions provide warnings of areas of operation that could cause damage to appliances.
Cautions are identified by a light red background.

CAUTION:
Text

m Examples are presented throughout the manual for deeper understanding of specific
concepts. Examples are identified by a pale green background.

EXAMPLE
Text

m Best Practices identify Exinda recommended methods for achieving the best from your
Exinda appliances and the Exinda Management Center. Best Practices are identified by
their light blue background and the "thumbs-up” icon.
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Best Practice:
It is a best practice to
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8 How Edge Cache Works

How Edge Cache Works

Edge Cache enables single-sided caching of Internet-based content, including web objects, videos
and software updates. Edge Cache requires only one Exinda appliance.

When web objects are downloaded from the Internet or across WAN links, Edge Cache stores them
at the edge of the network. When subsequent requests come for the same material, the content is
quickly delivered from Edge Cache, without the need to download the data again over the WAN. The
result is the ability to experience LAN speeds of WAN objects, and provide users with a better
network experience.

Edge Cache also supports HTTPS sites allowing the appliance to be a forward proxy and decrypt
content for caching. This is important as more and more applications and services are moving to
the cloud. These SaaS-based applications are typically delivered over HTTPS and so to be
effective, Edge Cache must support caching this HTTPS traffic.

Edge Cache also offers cache statistics, which provide insight into the amount of repetitive data
being off-loaded from the WAN link, how cacheable the network data is, and how frequently the
cache is being accessed.

Caching Internet-based Content

To cache web traffic, a client-side Exinda appliance is put in line with the traffic. When a network
user visits a URL with cacheable content, Edge Cache first determines if the content is available in
its cache. If not, Edge Cache retrieves the content from the URL. Upon retrieving the content, it is
stored in the cache with its expiry date as specified on the source website. This assumes that the
content is cacheable and falls within the Edge Cache setting parameters, such as size of object
and whether or not the URL is blacklisted. The next time a network user visits the same URL, Edge
Cache determines that the content is available in the cache and that the content is not stale by
looking at the object expiry date. The content is then served to the client from the cache, rather
than retrieving from the URL over the WAN.

Edge Cache uses a least recently used (LRU) algorithm for expiring cached data to make room for
new objects. This means the most popular and most used content is stored the longest. You also
have the ability to manually clear the entire cache if desired.

Edge Cache operates as a transparent proxy since it is running on an inline device. As a result, your
browsers do not need to be configured with an explicit proxy configuration.
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How Edge Cache Works 9

Caching Encrypted Internet-based Content

Version Info:
. As of version 7.0.2, Edge Cache can cache HTTPS content, as well as HTTP content.

When the network user visits an HTTPS URL, if HTTPS caching is not enabled, Edge Cache is
unable to determine what is being requested because the traffic is encrypted, including the

URL being requested. Even if it could cache the encrypted data, the next request for the same
HTTPS URL would not contain the same cached data because the encryption pattern would be
different. By enabling HTTPS caching, Edge Cache is able to act as a forward proxy, and retrieve the
content from the server, decrypt it, and provide it to the client over an encrypted communication
channel. Later requests can then be served from the cache.

To support this feature, you need to upload a trusted certificate to the appliance, which is then
used by Edge Cache to sign all dynamically generated site certificates. All client devices must
trust this certificate as a signing authority.
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10 How Edge Cache Works

To cache encrypted web traffic, the client tries to communicate with the HTTPS web server. The
Exinda appliance intercepts, keeping the communication open with the client. Then Edge Cache
tries to establish a conversation with the server. Upon receiving the certificate details from the
server, Edge Cache extracts the certificate details, constructs a new certificate and signs it using
the signing certificate that was loaded and specified in the Edge Cache settings. Edge Cache then
presents this new certificate to the client. The client trusts this certificate because the details
match its HTTPS URL request as the client has previously been told to trust anything signed by
this signing certificate (see below). The communication negotiation between the client and Edge
Cache is now complete. The client then requests the specific web object from Edge Cache as if it
were the server. Edge Cache then requests the web object from the server over its previously
established trusted connection. The server provides the content to Edge Cache, which then stores
the content, if applicable. The connection with the server can be closed. Edge Cache then serves
the content to the client and the connection with the client can then be closed.

IT Client Edge Cache Server

Upload signing CA certificate o

Cal

Initiate S5L negotiation with Server

A 4

Initiate SSL negotiation with Server

L 4

Return S5L certificate

M

Create 550 certificate using

details from the certificate

returned by the Server & sign it

using the signing certificate
Return dynamic S5L certificate

A

Request web object on Server

> Reguest web object on behalf of the Client -
i

Return web object

Decrypt the web object
and store it in the cache

Encrypt the web object using

the dynamic 550 certificate
Return web object over encrypted channel

i
al

Figure - Sequence of operations for caching encrypted traffic using Edge Cache

When determining whether the content should be stored in the cache, Edge Cache evaluates
whether it is the appropriate size and whether it is white- or black-listed. The whitelist and blacklist
can consist of source IP, destination IP, source domain, and destination domain. Note that the
domains are resolved using DNS, so the resulting IP addresses are reverse mapped to determine
the domain that is used to configure the Edge Cache engine.
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How Edge Cache Works 11

The next time a client requests the same content, the same negotiation happens where the client
requests a secure communication channel with the server, the Exinda appliance intercepts and
forms a secure communication channel with the server, forges the certificate and establishes a
secure communication channel with the client (on behalf of the server). The client then requests
the specific web content. Edge Cache determines that the requested content is available in cache
and serves it to the client. Edge Cache then closes the communication channels with both the
server and the client.

Client Edge Cache Server

Initiate SSL negotiation with Server

> Initiate SSL negotiation with Server

b 4

Return S5L certificate

M

Create 551 certificate using

details from the certificate

returned by the Server & sign it

using the signing certificate
Return dynamic S5L certificate

M

Reguest web object on Server

2>
Q Find the web object in the cache

Encrypt the web object using

the dynamic S5L certificate
P Return web object over encrypted channel
o

Figure - Sequence of operations for use of previously cached objects from encrypted sites using Edge Cache

Licensing

The Edge Cache Acceleration feature is a separately licensed component. To see if you are
licensed for Edge Cache, go to Configuration > System > Setup > License. You are licensed for
Edge Cache, if Max Edge Cache Connections is listed and is greater than 0. For more details about
licensing, see Licensing in the main user guide.

Please contact your local Exinda representative if you wish to enable this feature.

Overview - Configuration & Usage

To use Edge Cache,you'll need to ensure all the required configuration is set.
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12 How Edge Cache Works

Configure the Edge Cache settings, including:
o indicating what size of objects you want to cache

o specifying how long you are willing to let Edge Cache wait for a response from the WAN when
fetching objects

o specifying the signing certificate and private key if you plan to cache content from HTTPS
sites

o specifying blacklisted sites to not cache, or specifying to only cache whitelisted sites (for
HTTPS sites only)

o clearing out the cache, if desired.

o Version Info:
. Before version 7.0.2, Edge Cache requires you to restart the Edge Cache process

after making any modifications to the Edge Cache configuration. With 7.0.2 and
later, the Edge Cache process automatically restarts when needed.

For more details, see Edge Cache Configuration.

You also need to ensure that the DNS server configuration information is set. See DNS Con-
figuration.

For HTTPS caching, you need to ensure that the certificate used for HTTPS caching is trusted
by your clients. See Preparing & Trusting a Certificate for Encrypted Traffic.

If you have an upstream proxy in your environment, you can configure it as a proxy peer to
ensure that Edge Cache can fetch content from the Internet.

You can add one or more Edge Cache policies to a virtual circuit in the Optimizer.See Creating
an Edge Cache Policy in the Optimizer. Then you can start the Edge Cache process.

Since the appliance has dynamic disk partitioning, if needed, you can increase the cache stor-
age capacity dynamically. See Allocate Disk Storage for System Services in the main user guide.

Once Edge Cache is configured and started, you can monitor the caching performance.

m You can look at the Edge Cache monitor to determine the reduction ratio or throughput com-

paring the LAN (cached and non-cached) data to the WAN (non-cached) data. The Edge Cache
monitor will also report the requests per second versus the hits per second, where hits are the
number of requests that could be satisfied by cached content. These charts can look at long
term historical caching or can be as little as the last 5 minutes with 10 second samples. See
Edge Cache Report.

You can also look at the Real Time page to see which conversations are passing through Edge
Cache. Conversations with a blue background indicate that the flow passed through Edge Cache,
however, it does not necessarily mean that any of the requests were satisfied by cached con-
tent. See Monitor Edge Cache Traffic in Real Time.
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Configuring Edge Cache

To correctly configure Edge Cache, you need to take the following steps:
m Configure the DNS

m Create one or more Edge Cache policies in the Optimizer

m Configure the Edge Cache settings

m If you expect to cache encrypted traffic, prepare a trusted certificate for Edge Cache to use to
re-encrypt the traffic and distribute that trusted certificate to all of your client machines.

Edge Cache Configuration

When web objects are downloaded from the Internet or across WAN links, Edge Cache stores them
at the edge of the network. When subsequent requests come for the same material, the content is
quickly delivered from the Edge Cache without the need to download the data again over the WAN.
Edge Cache can cache web objects, videos, software updates, and other content on the WAN. You
can control whether to exclude particular sources, or sizes of objects from being cached. The
cache objects can also be shared among peer appliances if desired, meaning that if the content
cannot be found in the cache of the appliance through which the traffic is passing, then the
appliance can request the content from peer appliances. You are also able to clear the cache, if
desired.

You may want to limit the size of objects that can be cached. Since the cache storage size is
limited, you may want to decide whether to allow a few large objects or lots of little objects. You
should ensure that the size is aligned with the types of objects that you want to be cached. For
example, iOS updates tend to be approximately 1 GB and Mac updates tend to be 6 GB and so if you
want Edge Cache to help with caching of these updates, you'll want to ensure that the minimum
and maximum allowed objects size accommodates these sizes.

You may want to blacklist particular sites if Edge Cache is not working properly and is preventing
the network user from getting access to the site. Also, you may want to blacklist secure sites
because you do not want to cache sensitive data such as financial or banking sites. Alternatively, if
you want to only cache particular secure sites once they've been identified as important to your
network, you can whitelist them such that only those sites listed will be cached. Whitelisting is
only available for HTTPS caching. You can specify your whitelist and blacklist as source IP,
destination IP, source domain, or destination domain. Domains are resolved using the DNS.

To use HTTPS caching, you will need to specify which signing certificate will be used by Edge
Cache to generate a certificate to negotiate with the client on behalf of the server.
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14 Configuring Edge Cache

&% Version Info:

-r For versions prior to 7.0.2, Edge Cache requires you to restart the Edge Cache process
after making any modifications to the Edge Cache configuration. With 7.0.2 and later,
the Edge Cache process automatically restarts when needed.

NoOTE

Objects in the traffic that are matched with an Edge Cache policy but are excluded from
storage in Edge Cache due to these settings, will still pass through Edge Cache unprocessed
and will be highlighted on the Real Time conversations screen in blue (indicating that they

passed through and were evaluated by Edge Cache).

~0

|

Where do | find this functionality?
Go to Configuration > System > Optimization > Edge Cache.
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Configuring Edge Cache 15

To set the range of object size that you would like to cache

Memory Object Options

Min Object Size |p kB

Max QObject Size  |g190000 | kB

Connection Timeout |20 seconds

Apply Changes

Figure - Setting the size of the objects that can be cached

1. In the Memory Object Options area, type the minimum and maximum size of the objects to be
cached.

Only objects that are within this size range will be stored in Edge Cache.
2. Click the Apply Changes button.

Version Info:

. For versions prior to 7.0.2, you will need to restart Edge Cache for the changes to
take effect. Go to Configuration > System > Optimization > Services, and click the
Edge Cache Restart button.
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16 Configuring Edge Cache

To set the fetch connection timeout

Memory Object Options

Min Object Size | KB

Max Object Size  (g190000 | KB

Connection Timeout |20 seconds

Apply Changes

Figure - Setting the connection timeout

1. In the Memory Object Options area and in the Connection Timeout field, type the maximum
time in seconds that the Edge Cache will wait for a response from the WAN when fetching
objects.

You may need to increase this if connection timeouts are occurring regularly. Browsers
typically return a message similar to the following when this occurs: (110) connection
timed out

2. Click the Apply Changes button.

Version Info:
| Y

. For versions prior to 7.0.2, you need to restart Edge Cache for the changes to take
effect. Go to Configuration > System > Optimization > Services, and click the Edge
Cache Restart button.

To blacklist certain HTTP URLSs to never cache
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URL Deleie
docs.exinda.com Delete
Add URL/Domain
RL
Add URL

Figure - HTTP caching with blacklisted sites

. In the Add URL/Domain area, type the HTTP URL or domain that will be excluded from the

Edge Cache.
. Click the Add URL button.

. Repeat until you have your desired blacklist.
. Remove an HTTP URL or domain from the list by clicking the Delete button for the specified

17

URL/domain.
> Version Info:
. For versions prior to 7.0.2, you need to restart Edge Cache for the changes to take

effect. Go to Configuration > System > Optimization > Services, and click the Edge

Cache Restart button.

© 2016 Exinda Networks Inc.




18 Configuring Edge Cache

To blacklist certain (encrypted) HTTPS URLs to never cache
All https traffic can be cached according to the policy except those sites listed in the blacklist.

HTTPS Caching

Enasle caching of HTTPS Contents

Signing Certificate edge-cache-cert %

HTTPS Site Exceptions | | Only allow spedified {whitelisted) HTTPS sites to be cached
{E} Atternpt to cache all HTTPS sites except for blacklisted exceptions

Apply Changes

Configure which HTTPS URL/Domains to not cache

Type Value Delete
Cestination Domain wwwl.royalbank.com Delete
Destination Domain easyweb.td.com Delete
Source [P 10.6.2.251/32 Delete

Add IP or Domain

Type | Source IP ¥ | Walue

Add To List

Figure - Enabling HTTPS caching with blacklisted sites
1. In the HTTPS Caching area, select the Enable caching of HTTPS content checkbox.

£ NoTe
N You cannot enable caching if DNS is not configured.

2. Select the signing certificate to use to re-sign the traffic.
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Configuring Edge Cache 19

3. Select Attempt to cache all HTTPS sites except for blacklisted exceptions from the drop-down
list.

4. Click the Apply Changes button.

5. In the Add IP or Domain area, specify the type of traffic you want to blacklist and the Value(IP
or domain name) for that type of traffic.
You can specify Source IP, Destination IP, Source Domain, or Destination IP.

Domains are resolved using the DNS. Ensure the domains are in the format that are required
by DNS (i.e. without https://).

The specified domain name is resolved to an IP address, then the IP address is reverse
mapped to the actual domain name that corresponds to that IP address. Note that the domain
name may resolve to multiple IP addresses and multiple other domain names.

6. Click the Add URL button.
7. Repeat until you have your desired blacklist.

£ NoTE
\ The blacklist takes effect inmediately as Edge Cache automatically restarts.

8. Remove an HTTPS URL or domain from the list by clicking the Delete button for the specified
URL/domain.

To only allow specified whitelisted (encrypted) HTTPS URLs
Only https traffic specified in the policy and in this whitelist will be cached.
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20 Configuring Edge Cache

HTTPS Caching

Enable caching of HTTPS Contents lg

Signing Certificate edge-cache-cert | &

HTTPS Site Exceptions {f} Only allow specified (whitelisted) HTTPS sites to be cached

Atternpt to cache all HTTPS sites except for blacklisted excegtions

Apply Changes

Configure which HTTPS URL/Domains can be cached

Type Value Delete
Destination P 106.21.113.215,/32 Delete
Destination Domain WL youtube.com Delete

Add IP or Domain

Type Source P ¥ | WValue

Add To List

Figure - Enabling HTTPS caching with whitelisted sites

1. In the HTTPS Caching area, select the Enable caching of HTTPS content checkbox.

Note: You will not be able to enable caching if DNS is not configured.

Select the signing certificate to use to re-sign the traffic.

Select Only allow specified whitelisted HTTPS sites to be cached from the drop-down list.
Click the Apply Changes button.

In the Add IP or Domain area, specify the type of traffic you want on the whitelist and the Value
(IP or domain name) for that type of traffic.

You can specify Source IP, Destination IP, Source Domain, or Destination IP.

Domains are resolved using the DSN. Ensure the domains are in the format that are required
by DNS (i.e. without https://).

The specified domain name is resolved to an IP address, then the IP address is reverse
mapped to the actual domain name that corresponds to that IP address. Note that the domain
name may resolve to multiple IP address and multiple other domain names.

6. Click the Add URL button.

ok~ 0PN
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Configuring Edge Cache 21

7. Repeat until you have your desired whitelist.

£ NOTE
N The whitelist takes effect immediately as Edge Cache automatically restarts.

8. Remove an HTTPS URL or domain from the list by clicking the Delete button for the specified
URL/domain.

To not blacklist or whitelist any URLs

Set the blacklist mode, but do not add any URLSs.
This allows all sites to be cached except those listed. Since the list is empty, all sites are allowed.

To clear the Edge Cache cache

The clear action removes all objects from the memary.

Clear

Click the Clear button.
This removes all objects from storage.

To manage with which appliance peers to share Edge Cache content

When Edge Cache appliance peers are specified, if the requested content is not available in the
appliance's cache, Edge Cache can request the content from it's appliance peers.
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Add New Peer

Host Mame:  |axinda-toronto

Relationship: @

HTTP Port: |gp

ICPPort: |313p

Add Mew Peer Cancel

Figure - To add a new peer appliance for Edge Cache

Add Mew Peer

Host Mame Type HTTF Port ICP Port Edit

Delete

exinda-torontc  parent 80 3120 Edit

o gk 0D

Delete

Figure - Peer appliances for Edge Cache

. Click theAdd New Peer button.

An Add New Peer screen appears.
Type the Host Name of the peer.
Select the Relationship with the peer.
Type the HTTP Port of the new peer.
Type the ICP Port of the new peer.

Click the Add New Peer button.
The peer appears in the list of configured peers.

Peers can be edited or deleted by clicking the Edit or Delete button for the specified peer.
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Preparing & Trusting a Certificate for Encrypted Traffic

When caching encrypted content, you need to specify a certificate that Edge Cache can use to
create and sign a dynamically created certificate on behalf of the server. You need to ensure that
this certificate is trusted by all the computers on your network that have traffic passing through
Edge Cache. It is recommended that you create a self-signed CA certificate (as opposed to a self-
signed certificate without the CA designation) to simplify the loading and trusting of the certificate
by the computers in your network.

How to create a self-signed CA certificate for Edge Cache to
use

When using Edge Cache for encrypted traffic, you must create and import a signing certificate in
the Certificates and Keys store. This certificate and its corresponding key are used by Edge Cache
to generate and sign dynamic SSL certificates for proxied sites. For all practical purposes, this
certificate becomes a root certificate and you become a Root CA.

To create a CA certificate and private key using OpenSSL

Use the following OpenSSL commands:

openssl genrsa -out myCompanyCA.key 2048

openssl reqg -x509 -new -key myCompanyCA.key -out myCompanyCA.cer -days 1000
-subj /CN="myCompany CA”

This will generate two files: a.key file and a .cer file that can be uploaded in the CA certificates
ul.
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24 Configuring Edge Cache

To import your CA certificate and private key to the appliance’s Certificates and Keys store

Import Certificate and Key Details

Mame {optional)

Certificate/Key Format @ prcsez
PEM

Key Passphrase (optional)

Certiicate Fle || poee | Mo file selected.

Private Key File

Browse. .. | Mo file selected. {optional)

Figure - Import certificate in CA Certificates store

1. Go to Configuration > System > Certificates > CA Certificates.
2. Select the Import Certificate radio button.

3. (Optional) Type a Name for the certificate. If no name is specified, the filename of the
certificate is used.
Private keys are stored separately from certificates, and are automatically named the same as
the certificate, with '_key' appended to the end.

4. Select the Certificate/Key Format.

m PKCS#12—Format used when the certificate and key are stored together, and usually have
extensions such as .pfx and .p12..

m PEM—Common format for certificates issued by Certificate Authorities. PEM certificates
usually have extentions such as .pem, .crt, .cer, and . key. If PEM format is selected, an
additional upload field is exposed so that the private key can be uploaded with the
certificate.

5. If the key is password protected, in the Key Passphrase field type the password.

6. In the Certificate File field, click Choose File and navigate to the file to be uploaded to the appli-
ance.

7. If the PEM format is selected, the private key must be uploaded. In the Private Key File field,
click Choose File and navigate to the private key file.

8. Click Import.
The certificates are displayed in the Certificates and Keys table on the CA Certificates and

Keys table on the CA Certificates tab. From the tables the contents of a certificate can be
viewed, or the certificate can be deleted or exported.
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How to export the certificate for use on client computers

If the browsers in your network do not trust the certificate, you may get a warning or the sites may
fail to load. In this case, each computer needs to import the certificate so that the certificate will
be trusted when negotiating with Edge Cache over SSL.

You will need to export the certificate from the appliance and import it to the desired computers.

To export the certificate from the appliance:

1. Go to Configuration > System > Certificates > CA Certificates and find your desired certificate in
the list.

2. Export the certificate by clicking the Export button.

3. Ensure that the Export Certificate Format is set to PEM.
The PEM format encodes the certificate and private key. It may include an entire certificate
chain including public key, private key, and root certificates.

4. Click the Save button.

How to deliver and install the certificate on machines across
your network

The method used to install the trusted certificate on client machines depends upon both the
browser and the operating system:

Chrome and Explorer on Windows machines

Both Chrome and Internet Explorer on Windows Machines use the Windows certificate store to
trust the Exinda Edge Cache SSL certificate. Two methods are available to distribute the
certificates: using a domain controller or using a manual method.

To use a Domain Controller:

In this case, it is recommended that you follow the instructions provided by Microsoft to use a
domain controller to distribute the certificate:

http://technet.microsoft.com/en-us/library/cc772491.aspx

s )

£ NoTE

\ These instructions assume that you are using a domain controller or a workstation running
the domain admin MMC snapins while logged into a domain as a domain admin. Some of
the elements that are referred to in the instructions will not exist if you are using Windows
Server 2008 R2.

|

To use the manual method:
Follow this method to add the certificates to the Trusted Root Certification Authorities store on
each local computer.
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In the Windows Search field, type mmc, and then press ENTER to launch the Console screen.
Click File > Add/Remove Snap-in.

Under Available snap-ins, click Certificates,and then click Add to move the Certificates option
to the Selected snap-ins list.

In the pop-up window, select the Computer Account option under 'This snap-in will always man-
age certificates for' and then click Next.

Click Local computer, and click Finish.

In the console tree, double-click Certificates.

Right-click the Trusted Root Certification Authorities store.

Click Import to import the certificates and follow the steps in the Certificate Import Wizard.

Chrome on Linux machines

To install the trusted certificate on Linux machines for Chrome, you must use the NSS command
line tools. To import a personal certificate and private key stored in a PKCS12 fiel, use the
command below, substituting the details between the <> with the certificate file name.
pkl2util -d sqgl:$HOME/.pki/nssdb -i <PKCS12 file.pl2>

If the certificate was generated as a root CA certificate, use the following command, substituting
the details between the <> with the certificate nickname and file name.

certutil -d sqgl:$HOME/.pki/nssdb -A -t "C,," -n <certificate nickname>
-i <certificate filename>

Firefox on Windows machines

Mozilla Firefox uses its own certificate store and requires a unique process to trust the
certificate.

1.

ok~ 0D

Launch the Firefox browser.

Go to Options > Advanced > Certificates.

Click View Certificates.

Click Import.

Navigate to the certificate you generated and exported from the Exinda appliance and import it.

MAC 0S

If installing the certificate on a MAC, you must use the Keychain Access program. To start the
Keychain Access program,double-click certificate file.

If you are importing a CA certificate:

Double-click the exported PEM file for the CA certificate to start the Keychain Access program.
When prompted, type your computer's admin password.

The Keychain Access window appears.

The certificate has automatically been installed with no additional steps.
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If you are importing a non-CA certificate:
1. Double-click the exported PEM file for the non-CA certificate to start the Keychain Access
program.
2. When prompted, type your computer's admin password.

3. Inthe Keychain Access window, select the System keychain to install for all users on the
machine, or Login keychain to install only for the current user account.

4. Find the desired certificate in the list and right-click and select Get Info.
5. In the Trust section, select Always Trust for the When using this certificate drop-down list.

Configuring DNS

If DNS is not configured, Edge Cache will not work properly. That is the DNS server(s) must either
be specified on Configuration > System > Network > DNS or by selecting DHCP on Configuration >
System > Network > IP Address.

The user interface will not allow you to get into a state where DNS is not configured when using
HTTPS Caching. For instance, if DNS is not configured, then a warning will be shown next to the
HTTPS Caching section and the enable checkbox will be disabled. Also if HTTPS Caching and DNS
are configured, and you attempt to remove DNS configuration, then the system will warn you and
prevent you from making the change.

CAUTION

A The system does not prevent using non-encrypted caching when DNS is not configured. In
this case, the system will not warn you and Edge Cache will fail. The logs will report the
issue.

To learn more about configuring DNS. See DNS and Domain Names Configuration in the main user
guide.

Creating an Edge Cache Policy In the Optimizer

Edge Cache works on outbound, HTTP based conversations (and HTTPS based conversations, for
version 7.0.2 and later). To enable Edge Cache, create a policy that will capture the HTTP
application traffic that you wish to cache and add the policy to the appropriate virtual circuit in the
Optimizer. You can specify a subset of the network to use Edge Cache by specifying the source
network object.
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A CAUTION:

You can create an Edge Cache policy on anything except a L7 signature. That is, you can
set the policy filter using VLAN, source and/or destination network objects, ToS/DSCP, or
applications that are based on protocol, ports, network objects, or DSCP.

NOTE:

It is possible to shape traffic that is being cached on the first pass. However, there is one
extra consideration. Traffic hitting the Edge Cache engine is only shaped by the policy
configured for the “Web” application-group or the HTTP/HTTPS application objects. For
example, if a flow being classified as “Software Updates” is falling under the “Software
Updates” policy, it is actually shaped as using the “Web” policy settings.

‘o

|

To learn more about configuring policies, see Policy in the main user guide.

Edit Policy

Policy Name: ‘Gmewcb,o,mmﬁng ‘ ) Guaranteed Banawidth:
Schedule: Burst (Max) Bandwidth:
Action: Burst Priority: | 1y —
PolicyEnables: 4 Acceleratiors
@] Packet Marking
Filter Rules: VLAN Source Direction Destination ToS/DSCP Application
[ Marketing #] [ Both :] [ALL :] [ALL :] [ HTTP :]
AL $ [ Marketing #] [ Both :} [ALL :] [ALL :} [ HTTPS é]
D | ) [ | i |
B | ) [ | i |
5 | J DR N i |
3 U O | | ] | g

To create an Edge Cache policy

1. Click Optimizer > Policies > Create New Policy or click Create New Policy in the appropriate vir-
tual circuit.

2. Type a name for the policy.

3. Select the Acceleration checkbox and select Edge Cache from the Acceleration list.

4. Create the filter rules for the policy, ensuring that HTTP (or HTTPS) or an application based on
protocol, port, network object, or dscp is selected from the application list.

5. Click Add New Policy.

To apply Edge Cache to a subset of the network
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1. When creating the policy, specify a network object as the source in the policy filter.
2. Click Add New Policy.
Only the traffic in that source network object will use Edge Cache.

29
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Reporting

You can see the effectiveness of Edge Cache by either looking at the Edge Cache monitor or by
looking at Real Time conversations.

Edge Cache Report

The Edge Cache Report shows the reduction in the amount of traffic achieved due to caching
techniques and the number of requests and the number of hits from the cache. These charts can
answer questions such as, “How much traffic reduction am | getting due to Edge Cache?” "How
cacheable is the network data and how frequently is the cache being accessed?”

The chart can show the traffic reduction over time as either throughput or percentage reduction.
The reported LAN throughput is the amount of traffic that was served to the client whether it was
served from Edge Cache or not. This represents all traffic that was handled by Edge Cache
policies. The reported WAN throughput is the amount of traffic that was not available in Edge
Cache and needed to be retrieved from the application server. Therefore, the difference between
WAN and LAN is the amount of traffic that could be served from Edge Cache.

When reduction statistics are displayed as throughput, there is one time series plotted for LAN
throughput and one for WAN throughput. You should expect the LAN throughput to be higher than
WAN throughput. When the LAN throughput is greater than the WAN throughput, the more traffic
was served up from Edge Cache than was needed to be retrieved from the WAN.

Edge Cache Throughput
4 Ohdhps
3.ahbps :L\
3.0Mbps
2 5Mbps

2 0Mbps
1 Shbps

1 .OMbps '
0.5hbps S |
e

] I T 1
04: 00Pk 10:00Pk 04:004h 10:004h 04:00Pk
12 May 11 12 May 11 13 hay 11 13 May 11 13 May 11

LAN Data VAN Deta

When displayed as percentage reduction, it displays one line graph to represent the percentage of
data transferred that was sent from Edge Cache instead of from the application server.
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The Edge Cache Statistics chart display the number of requests per second and the number of hits
per second. A request occurs when Edge Cache is checked for particular data. A hit occurs when a
request is satisfied by an object already stored in the Edge Cache.

Edge Cache Statistics
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The table shows a summary of Edge Cache reduction for the selected time period.

LAN {MB)
2138.61

Where do

WAN (MB)
1930,90

Reduction Ratio (%)

1

Hits Hit Ratio (%)

B

Requests

.71 204030 120030

| find this report?

ad.83
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Go to Monitor > Optimization > Edge Cache.

How do | change the Edge Cache Throughput chart to a Edge Cache Reduction Ratio chart?
Select the desired type of chart from the Edge Cache Graph Type selector below the chart.

How is the Edge Cache Reduction Ratio calculated?

Reduction Ratio = (Data Transfer Size Before Exinda - Data Transfer Size After
Exinda) / Data Transfer Size Before Exinda

Monitor Edge Cache Traffic in Real Time

The Conversations in Real Time monitor shows the top conversations by throughput observed by
the Exinda appliance during the last 10 seconds. This report can answer questions such as, “Is the
traffic being processed by Edge Cache properly?”

The Conversations in Real Time monitor shows inbound conversation traffic separately from
outbound conversation traffic.The conversations are represented as external IP, internal IP, and
application. For HTTP or HTTPS, the URL will appear in square brackets following the application.
The traffic is sorted by transfer rate. The packet rate and number of flows for each conversation in
that 10 second period is also shown. You can set the chart to refresh frequently or infrequently or
not at all. Each refresh shows 10 seconds of data.

Inbound Conversations

External IP Internal IP Application Transfer Rate Packet Rate Flows

(kbps) (pps)
Total 1408.428 284 24
SJ__] 192.168.10.1 192.168.10.128 MAPT 570.834 82 1
SJ__J 192.168.10.9 192.168.10.128 MAPT 483.247 54 2
SJ__J 192.163.10.7 192.168.10.128 MAPT 275.334 92 2
SJ__J 192.168.10.10 192.163.10.128 MAPT B65.153 51 2
192.168.10.7 192.168.10.128 HTTPS[perf-win2ka] 5.496 1 1
SJ 192.163.10.9 192.163.10.128 LDAP 2.939 1 1
10.20.4.1 239.255.255.250 udp ports 62612 -= 3702 1.097 0 1
10.20.4.1 239.255.255.250 udp ports 62610 -= 3702 1.069 0 1
192.163.10.1 192.168.0.1 NetBIOS 0.623 1 1
192.168.10.10 192.1635.10.123 LOAF 0.556 0 2
192.1638.10.132 255.255.255.255 DHCP 0.541 0 1
192.168.10.9 192.168.0.1 NetBIOS 0.225 0 1
10.20.3.118 10.20.255.255 NetBIOS 0.225 0 1
192.168.10.9 192.168.255.255 NetBIOS 0.225 0 1
10.20.11.100 224.0.0.252 udp ports 58633 -= 5355 0.212 0 1
10.20.0.14 10.20.255.255 NetBIOS 0.193 0 1
192.163.10.9 192.1638.10.128 LOAP 0.174 0 1
SJ 192.168.10.1 192.168.10.128 MSRPC 0.106 0 1
192.168.10.9 192.1635.0.1 DNS 0.102 0 1
10.20.0.181 10.20.255.255 NetBIOS 0.075 0 1

When a conversation has been processed by Edge Cache, it is highlighted in blue.
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74,125,237.41 172.16.0.96 HTTP[books.google.com] 0.366

£ NOTE:

All conversations that are evaluated by Edge Cache will be highlighted in blue even if the
object is excluded from storage in Edge Cache due to Edge Cache settings.

To learn more about this monitor, see Conversations in Real Time in the main user guide.
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Troubleshooting Edge Cache

I do not know if Edge Cache is caching any traffic

m You can determine if any traffic is passing through Edge Cache by looking at the real time

conversations monitor available at Monitor > Real Time > Conversations.

Any traffic that is currently being processed by Edge Cache will have a blue background. This
will tell you if Edge Cache is evaluating whether data could be retrieved from its cache or
evaluating whether the data should be stored in it. However, it does not indicate whether it is
successful in either retrieving or storing the data.

You can determine if any traffic has passed through Edge Cache over time by looking at the
Edge Cache report available at Monitor > Optimization > Edge Cache.

The Edge Cache monitor report will show the amount of data over time processed through Edge
Cache served on the LAN and the amount of data retrieved from the WAN. It will also show the
requests to Edge Cache and the hits. These two charts will show you if data is going through
Edge Cache and if so how many hits and how much data is served from the cache.

Check the logs for any errors related to Edge Cache, including DNS not being configured.

You should ensure that DNS is configured properly by visiting Configuration > System > Network
> DNS. For help configuring DNS, see the main user guide.

If the Real Time monitor and the Edge Cache monitor indicate that data is not passing through
Edge Cache, you should ensure that the Edge Cache process is running.

Go to Configuration > System > Optimization > Services and ensure that Edge Cache is running.
You may want to restart Edge Cache.

I do not know if Edge Cache is caching encrypted traffic

All the steps for troubleshooting caching above apply.

Try browsing to an encrypted site then look at the real time conversations. The encrypted traffic
will be reflected in the application name, such as HTTPS. If processed through Edge Cache, the
conversation will have a blue background.

Ensure HTTPS caching is enabled and a certificate is configured.

If the traffic that you are concerned about is specified in a caching whitelist or blacklist using
source or destination domains, then try restarting Edge Cache at Monitor > Optimization

> Services. If the reverse mapped domains have changed, then the domains that are specified in
the whitelists and blacklists may need to be re-resolved and re-reverse mapped. This is done
upon Edge Cache startup, when there is a change to the whitelist or blacklist, or when there is a
change to the DNS information.

| want to increase the effectiveness of Edge Cache

You can restrict the size of the objects that can be cached to more closely match the type of
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data that you want cached by visiting Configuration >System > Optimization > Edge Cache.

= You can increase the amount of storage available for Edge Cache to use by visiting Con-

figuration >System > Setup > Storage.

What factors should | consider before starting Edge Cache on HTTPS for surf traffic?

Develop a list of sites that need to be white listed because of security concerns (for example fin-
ancial sites)

Deploy your self-signed certificate throughout the entire network if you do not want users to
accept the “false” certificate

Independent appliances (for example printer from various manufacturers) use HTTPS to connect
to maintenance sites to order cartridges and no human interaction is needed; therefore these
sites need to be white listed.

Payment terminals use HTTPS to accept payments and there is no option to install a self-signed
certificate

Some browsers (typically Google Chrome) check more than only the “trusted” self-signed cer-
tificate before allowing access to a specific web page

Why are some web pages rendering incorrectly?

If Edge Cache is not rendering layouts as expected, the problem is likely due to the certificate
format. Using the Certificate generator of the Exinda appliance lets you export PEM and DER
Certificate formats, but some formats require a PKCS12 certificate and these cannot be exported
from the Exinda appliance. To correct the problem, use openssl to generate Certificates and import
them into the appliance:

1.

2.

Use openssl to create your PKCS12 + private key and CSR file. The list of common command
lines for openssl to create your Certificates includes:

m Generate a new private key and Certificate Signing Request: openssl req -out CSR.csr
-new -newkey rsa:2048 -nodes -keyout privateKey.key

m Generate a self-signed certificate (see How to Create and Install an Apache Self Signed Cer-
tificate for more info): openssl req -x509 -nodes -days 365 -newkey rsa:2048
-keyout privateKey.key -out certificate.crt

m Generate a certificate signing request (CSR) for an existing private key: openssl req -
out CSR.csr -key privateKey.key -new

m Generate a certificate signing request based on an existing certificate: openssl x509 -
x509toreq -in certificate.crt -out CSR.csr -signkey privateKey.key

Import the certificate into the Exinda appliance:
a. Login to the appliance.
b. Click Configuration > System > Certificates.

c. Type a name for the certificate, then browse to location of the Certificate file and the Private
Key file.
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3.

4.

d. Click Import.

e. Switch to the All Certificates tab to ensure your import was successful.
Assign the PKCS12 certificate to Edge Cache.

a. Click Configuration > System > Optimization > Edge Cache.

b. Under HTTPS Caching, click the checkbox to enable HTTPS content caching, and then select
the PKCS certificate you created from the Signing Certificate list.
c. Click Apply Changes.

Import the PFX/PKCS12 certificate to your own computer. Reload the page that was formatted
incorrectly to ensure the new certificate solves the problem.

Are there any open issues | should know about?

The following open issues are known concerns:

Facebook does not work with Chrome

Facebook works with Safari but still has a pop-up

Google apps work with Chrome but they can only use the Google Certificate
Google apps work with Safari

Firefox still has pop-ups because it uses a different Certificate store
Outlook connects to Exinda without popups

© 2016 Exinda Networks Inc.



Command Line Interface (CLI) 37

Command Line Interface (CLI)

Edge Cache can be configured via CLI, such as configuring the Edge Cache settings including
specifying the object size to cache, cache timeout, blacklists and whitelists, and specifying
upstream peers. You can also import your CA certficates via CLI.

CLI: Edge Cache Acceleration

You can use the acceleration edge-cache command to configure Edge Cache acceleration.
Edge Cache enables single-sided caching of Internet-based content, including web objects, videos
and software updates. Edge Cache requires only one Exinda appliance.

When web objects are downloaded from the Internet or across WAN links, Edge Cache stores them
at the edge of the network. When subsequent requests come for the same material, the content is
quickly delivered from Edge Cache, without the need to re-download the data over the WAN. The
result is the ability to experience LAN speeds of WAN objects, and provide users with a better
network experience.

Edge Cache also supports HTTPS sites allowing the appliance to be a forward proxy and decrypt
content for caching. This is important as more and more applications and services are moving to
the cloud. These SaaS-based applications are typically delivered over HTTPS and so to be
effective, Edge Cache must support caching this HTTPS traffic.

Version Info:
. As of version 7.0.2, Edge Cache can cache HTTPS content, as well as HTTP content.

Configuring Edge Cache

acceleration edge-cache {administrator-email |application|cache|connect-timeout|enable-
https|https-black-1list|https-cert|https-list-type|https-white-list|never-cache|never-

direct|object-size|peer|range-offset}
no acceleration edge-cache {application|enable-https|https-black-1list|https-white-
list|never-cache|never-direct |peer}

To specify the maximum and minimum size of objects to store:

acceleration edge-cache object-size {maximum|minimum> <size>

<size> — The size parameter should use Sl units e.g. 100M or 512k.
To specify how long Edge Cache should wait for a response when fetching objects from the server:

acceleration edge-cache connect-timeout <seconds>
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To add or remove an HTTP URL or domain that should be blacklisted (i.e. should never be cached):

[no] acceleration edge-cache never-cache <URL or domain>
To add or remove HTTP applications that should be cached:
[no] acceleration edge-cache application <application>

application <application> - Note: Only applications that use the HTTP protocol are supported.
To enable [or disable] HTTPS caching:

[no] acceleration edge-cache enable-https

To specify the signing certificate to use to create dynamic SSL certificates during HTTPS caching:

acceleration edge-cache https-cert <cert-name>

To specify an HTTPS black-list of IPs or domains:
acceleration edge-cache https-list-type black-list
Specifies that Edge Cache will use a black-list for determining what sites can not be cached. All
others will be allowed.

acceleration edge-cache https-black-list {dest-domain|dest-ip|src-domain|src-ip}

m src-domain <domain> - The domain that initiated the conversation.

m src-ip <ip> - The IP that initiated the conversation. The IP can include a mask.

m dest-domain <domain> - The domain that was the destination of the conversation.

m dest-ip <ip> - The IP that was the destination of the conversation. The IP can include a mask.

m Note: Domains are resolved using the DSN. Ensure the domains are in the format that are
required by DNS (i.e. without https://)

To remove a domain or IP from the black-list:
no acceleration edge-cache https-black-list <internal ID>
https-black list <internal ID> — To determine the internal ID, type: no acceleration

edge-cache https-black-list 2, which presents the list of HTTPS black-list sites in the
format: Internal ID, Type, Value

To specify an HTTPS white-list of IPs or domains:

acceleration edge-cache https-list-type white-list

m Specifies that Edge Cache will use a white-list for determining what sites can be cached. No oth-
ers will be allowed.

acceleration edge-cache https-white-list {dest-domain|dest-ip|src-domain|src-ip}
m src-domain <domain> - The domain that initiated the conversation.

m src-ip <ip> - The IP that initiated the conversation. The IP can include a mask.
dest-domain <domain> - The domain that was the destination of the conversation.

m dest-ip <ip> - The IP that was the destination of the conversation. The IP can include a mask.
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m Note: Domains are resolved using the DSN. Ensure the domains are in the format that are
required by DNS (i.e. without https://)

To remove a domain or IP from the white-list:
no acceleration edge-cache https-white-list <internal ID>
m https-white list <internal ID>-To determine the internal ID, type: no acceleration

edge-cache https-white-list 2, which presents the list of HTTPS whit-list sites in the
format: Internal ID, Type, Value

To clear the object cache:

acceleration edge-cache cache clear

To configure an Edge Cache peer:

If you have an upstream proxy in your environment, you can configure it as a proxy peer to ensure
that Edge Cache can fetch content from the Internet.

[no] acceleration edge-cache peer <hostname> [http-port|icp-port|option]

m <hostname> - The hostname of the peer object memory.

m http-port <port>-The HTTP port for the peer command

m icp-port <port>-The ICP port for the peer command

m option default - Use the default peer options

m option proxy-only - Do not cache objects from this peer.

m option no-query - This peer does not support ICP

m option weight=n - Specify the peer priority. Peers with higher priority will be consulted first.
m option round-robin - Specify that peers should be consulted in round-robin order.
m option closest-only - Only forward closest parent ICP misses.

m option originserver - Specify that this peer is an origin server

To never fetch a file directly; always use the peer:

[no] acceleration edge-cache never-direct

To prevent delays when skipping ahead during video downloads:

acceleration edge-cache range-offset <limit>

Viewing configuration settings

To show the current Edge Cache configuration settings:

show acceleration edge-cache

CLI: Certificates

You can use the crypto command to import keys and certificates.

© 2016 Exinda Networks Inc.



40 Command Line Interface (CLI)

Configuring Certificates and Keys

crypto certificate [generate|import|setkey]

crypto key import

To import a certificate or key in PEM format:
crypto {certificatelkey} import <name> pem data "<pem-data>"

m import <name>- The name of the certificate or key.

m pem data <pem-data>- The PEM data. Ensure to quote the PEM data.
To generate a self-signed certificate:

crypto certificate generate self-signed <cert-name> instance {<instance-name>|exinda-
autogen}

To assign a key to a certificate:

crypto certificate setkey <certificate name> {key|test}
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