Answer
PROBLEM
While performing an import to GFI MailArchiver using the GFI MailArchiver Import Export Tool, the export process is paused with the following error:
A large number of emails have a date that does not match any of the date ranges covered by the databases configured. Export processes suspended indefinitely. Please check the manual for troubleshooting.
ENVIRONMENT
- GFI MailArchiver 2011
- GFI MailArchiver 6
- All Supported Environments
SOLUTION
You would first need to determine if you want to archive the emails in the Unclassified folder. If these emails do not need to be archived, you can delete the emails, and the GFI MailArchiver Import Export Tool will resume with the processing of other emails.
If the emails need to be archived, you would need to perform the following procedure to process the emails in the Unclassified folder:
- Browse to the ...\GFI\MailArchiver\MAIS\Unclassified directory
- Determine date range of emails in directory by opening .EML file and viewing received /sent date from the Email Message header
- Modify the Import Configuration within the Import Export Tool to include all dates from imported email
- Move emails from ...\GFI\MailArchiver\MAIS\Unclassified to ...\GFI\MailArchiver\MAIS\Queue
- The Import Service will now proceed archiving the emails.
Note: Spam emails are often sent with corrupt mail headers, making it impossible for the GFI MailArchiver Import Service to determine the date received for such emails. These emails will be found in the Unclassified folder, often with an incorrect date. It is recommended to delete such emails from the Unclassified folder.
CAUSE
The error above indicates that a large number of emails which are being extracted by the GFI MailArchiver Import Export Tool do not match the date range which has been configured in the GFI MailArchiver Import Configuration. Such emails will not be archived, and moved to the Unclassified folder, which can be located at <\GFI\MailArchiver\MAIS\Unclassified>.
In order to ensure a minimal amount of emails being exported incorrectly, once the Unclassified folder contains 500 emails, the GFI MailArchiver Import Export Tool is instructed to stop exporting emails and return the error above.
The names of the files which are stored in the Unclassified folder would indicate the date the email was received /sent. This will allow the Administrator to configure Archive Stores in the GFI MailArchiver Import Configuration to cover the period for the unclassified emails.
Emails in the Unclassified folder are renamed as follows:
[Year][Month][Server]_[UniqueID].eml
Example:
200811Exch07_[0344062031][2][426].eml