Overview
When upgrading a version 4.3 agent to 2012, the drivers are failing to start, and there are no devices that are being controlled.
Upon checking the agent log files, the following error messages are logged.
2013-01-09,10:16:58,265,3,"#000007bc","#000000cc","info ","DevicesController"," >> Start driver."
2013-01-09,10:16:58,265,3,"#000007bc","#000000cc","info ","DevicesController"," creating the driver esecdrv42 service from system32\drivers\esecdrv42.sys"
2013-01-09,10:16:58,265,3,"#000007bc","#000000cc","info ","DevicesController"," driver already registered." ... ...
2013-01-09,10:18:19,081,1,"#000007bc","#000000cc","error ","DevicesController"," error starting the driver: [2] The system cannot find the file specified.."
2013-01-09,10:18:19,081,1,"#000007bc","#000000cc","error ","DevicesController","<< error starting driver."
2013-01-09,10:18:19,081,1,"#000007bc","#000000cc","error ","DevicesController","<< failed initializing DevicesController."
2013-01-09,10:18:19,081,1,"#000007bc","#000000cc","error ","ServiceProvider"," error initializing plugin."
Environment
EndPointSecurity 2012 build 20120104
Root Cause
This is a known product defect in EndPointSecurity 2012 where the esecdrv42.sys file is missing from the Windows\system32\drivers folder.
Resolution
This defect has been addressed in EndPointSecurity 2013. You need to upgrade to EndPointSecurity 2013 to permanently resolve this issue. If an upgrade is not feasible at this time, you can uninstall the agent and install it again as a workaround.