Overview
Some devices are showing offline on EMC (Exinda Management Console) despite having access to the internet and showing online on EBS (Exinda Business Server) correctly. These devices can communicate with EBS, which has the same IP as EMC. However, they are unable to show up as online on EMC.
Upon checking the Exinda appliance logs, the following error messages are recorded:
sdpd[2590]: [sdpd.WARNING]: Statistics delivery failure to the central management system. 5 min stats dropped. Please check your central management system status and logs - SOAP failed with error 12, Transaction rolled back,
Root Cause
Identical host IDs are creating duplicate records of appliances on EMC. When this happens, the EMC is unable to update the right record in the database, and the transaction is rolled back.
Resolution
Make sure that the host ID field is unique on the database to avoid such issues from happening. Alternatively, you may also remove or delete the duplicate records of appliances on EMC if renaming the host ID field is currently not feasible.