Answer
PROBLEM
When viewing the GFI FaxMaker monitor, "Error initializing / opening database(s)" may be seen under the
Fax Server node or
Message Transfer Agent node.
ENVIRONMENT
-
GFI FaxMaker
-
all supported environments
SOLUTION
Use Windows Explorer to open the Services Management Console (start > run > services.msc)
-
If the error occurs under FaxServer of the GFI FaxMaker monitor:
-
Right click the GFI FaxMaker Fax Server service
-
Go to Properties of the service, Log on Tab
-
Ensure that the account running the service is a Domain Administrator (format: Domain\Administrator)
-
Note: If no domain is present, the account should run with a Local Administrator account (format: .\Administrator)
-
If the Error occurs under Message Transfer Agent of the GFI FaxMaker monitor:
-
Right click the GFI FaxMaker Message Transfer Agent service
-
Go to Properties of the service, Log on Tab
-
Ensure that the account running the service is a Domain Administrator (format: Domain\Administrator)
-
Note: If no domain is present, the account should run with a Local Administrator account (format: .\Administrator)
CAUSE
Lack of permissions on the service account may result in the above mentioned error.