Answer
PROBLEM
When deploying an agent or agents, the following error is displayed in the deployment history:
Failed to contact remote computer. Computer might be offline...
ENVIRONMENT
- GFI EndPointSecurity
- All Supported Environments
SOLUTION
- From the GFI EndPointSecurity machine, ping the computer by hostname and note the IP Address returned
- On the target computer, determine the current IP Address using the ipconfig command
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If the two IP addresses do not match, this is the source of the issue. Try the following:
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From the GFI EndPointSecurity machine's command prompt, run the command: Nslookup <Target_Computer_Name> and see if the IP address given matches the IP Address in #2 above. If the IP Addresses are different, it confirms the problem is that the local DNS server does not have the correct IP Address registered for the target machine. To address, on the target machine, run the following commands:
- ipconfig /release
- ipconfig /renew
-
ipconfig /registerdns
- Note: Any errors in the registerdns process may take 15 minutes to show up in the Event Log on the client computer
-
From the GFI EndPointSecurity machine's command prompt, run the command: Nslookup <Target_Computer_Name> and see if the IP address given matches the IP Address in #2 above. If the IP Addresses are different, it confirms the problem is that the local DNS server does not have the correct IP Address registered for the target machine. To address, on the target machine, run the following commands:
- If #3 fails to fix the issue, troubleshoot the issue of DNS / DHCP registrations on your network
CAUSE
Network configuration issues prevent GFI EndPointSecurity from resolving IP addresses correctly.