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When Blocking iMessage, Push Notifications Are Blocked

Overview

The Exinda appliance gives administrators multiple options to stop or throttle applications that can use a lot of bandwidth in the network. An application that many would consider discardable or able to be easily limited in bandwidth is iMessage.

When blocking or discarding iMessage traffic, users may experience an issue where all push notifications on iOS devices that have traffic going through the Exinda, i.e., on WiFi, will stop displaying.

 

Root Cause

Apple uses the Apple Push Notification Service (APNS) to allow application creators to push out information to iOS devices. This includes mail servers being able to push out notifications of calendar and email, or app creators to be able to push text-based messages straight to the device. iMessage, the iOS application that performs instant messaging, uses APNS as a back end, and it sets up a persistent connection with an iOS server.  When a user sends or receives a message, it is pushed to/from the server and then to the other party.

Because iMessage extensively uses the APNS infrastructure, the 'iMessage' classification will cover all APNS notifications. This means that if iMessage is discarded in an Optimizer policy, all APNS messages will be rejected, regardless of the application of origin, resulting in the issue described herein.  Likewise, throttling iMessage to a minimal bandwidth can cause latency or drops for APNS. APNS messages are small by default (limited to 2KB), and when combining many iOS users into a single policy based on iMessage, the bandwidth applied might not be enough.

 

Resolution

Remove the policy for discarding iMessage traffic or increase the bandwidth allocated to the policy.

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  1. Priyanka Bhotika

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