Overview
The article explains what needs to be done when Exinda WebUI is sluggish and/or freezes when trying to access it or browse through it.
Root Cause
This happens when the device is under a specific load such that the management front end is tied in a process loop. The process mgmtd is one of the processes responsible for handling the WebUI and its access. If mgmtd is stuck or waiting on some other process, then it will not be available till it has resources to function normally. This generally happens when:
- The device is under load and is passing a lot of traffic through it. The process collectordgets busy andmgmtdis hung up oncollectord.
- When there is a huge database roll up happening, the process datadis rolling up the database andmgmtdis stuck on MySQL anddatadand other related processes.
- In general, there is network latency. If network latency is high, then the WebUI access can be sluggish.
Resolution
The only resolution for this issue is to wait for some time. If the user tries to access mgmtd again after 15-20 minutes when the load cycle has passed, then mgmtd is available again.
Priyanka Bhotika
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