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Re-Indexing Corrupted User Folders Manually

Overview

The users might face file corruption issues and emails stuck in the Outbox. Following errors can be displayed:

Index error in folder ~johndoe@kerio-domain.com/Calendar: Cannot parse calendar message file 00000019.eml

Cannot open message file D:\Program Files\Kerio\MailServer\store/mail/kerio-domain.com/johndoe/Calendar/#msgs/00000019.eml. The file has been probably removed.

Since version 7.3.0, Kerio Connect repairs corrupted files by automatically re-indexing them through Webadmin. For the older versions or for the cases where the automatic re-indexing fails, you can manually re-index the corrupted files.


 

Prerequisites

Make sure to exclude the Kerio Connect folders from the Antivirus scanning. Find complete details in Antivirus Exclusions for Kerio Connect.

Diagnosis

The files are becoming corrupted or damaged during the unexpected service crashes or server outages. The internal files might also be occupied by another application or built-in OS service.

Solution

  1. Depending on the email client, log out of all mail sessions.

    1. Webmail:
      logout_webmail.png
    2. Kerio Connect Client:
      logout_kcc.png
    3. Outlook: close the application itself
  2. Stop Kerio Connect.

  3. Navigate to the Kerio store folder.

  4. Access the user directory via the following path (defaults):

    1. Windows: C:\Program Files\Kerio\MailServer\store\mail\domain.com\username\folder_name
    2. Linux: /opt/kerio/mailserver/store/mail/domain.com/username/folder_name
    3. macOS: /usr/local/kerio/mailserver/store/mail/domain.com/username/folder_name
  5. In the specific user folder directory (e.g., INBOX, Calendar), locate the index.fld file.

  6. Rename the index.fld file to index.bad.

    1.  Windows:

      016.png
    2. Linux:
      manipulations_linux.png
       
  7. Start Kerio Connect.
Kerio Connect re-builds the index file the next time you access your folder. If it is a large folder, there might be a slight delay in the re-building process.

 

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Testing

Log in to the Kerio Connect web administration interface, and check the error log. The error about .eml message file should have been resolved. 

 

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Additional Information

Each user folder (INBOX, Calendar, Sent Items, etc) contains its own index.fld file. One of the most common causes of inconsistencies in the index.fld file is a local anti-virus software that has not been configured to exclude the scanning of the mail server and the store directories. We strongly recommend using the built-in Bitdefender antivirus or one of the supported antivirus plugins included with Kerio Connect to scan messages for viruses.

 

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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