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A user cannot be added under Configuration > Access Control in GFI Archiver

Answer

PROBLEM

You try to add an entry under Configuration > Access Control, but the drop downlist does not populate with the user account you are looking for. The user you are trying to add does exist in Active Directory.

ENVIRONMENT

  • GFI Archiver
  • All supported environments

SOLUTION

Check the user object in the Active Directory domain and ensure that:
  • It is not disabled
  • It is mail-enabled (see the email field within Active Directory Users and Computers)
  • The Display Name is not blank
User-added image

Notes
  • You must type in at least 1 character into the field under Configuration > Access Control because GFI Archiver will not start searching as long as the field is blank
  • Please also read the following page, especially if running a non-Microsoft Exchange environment including Microsoft Office 365: http://go.gfi.com/?pageid=mar_directoryservicesettings

CAUSE

In order to populate the drop down lists under Configuration > Access Control GFI Archiver queries Active Directory using an LDAP filter. For example, the following query is used, when "Admin" is typed into the drop down list:
(&(objectCategory=user)(mail=*)(displayName=Admin*)(!(cn=SystemMailbox{*)))

The objects in Active Directory do not have attributes set which are required by GFI Archiver.
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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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