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LanGuard 12 Agent Upgrades Are Failing Following Version Upgrade of Console

Overview

After performing an upgrade of LanGuard from an earlier version to the latest release, you may on rare occasions find that the LanGuard Agent is not updating to the latest release to match the console upgrade performed. The Languard12Agent.msi file is missing, causing LanGuard Agent upgrades to fail.

Environment

LanGuard version 12.x.

Root Cause

During the upgrade, the Languard12Agent.msi file was not copied to ..\Program Files (x86)\GFI\Languard 12\Agent

Resolution

 If the file is missing, you need to obtain the .msi file to put it in place for the remediation job to grab and push to the agents requiring an upgrade.

  1. Select the installer for your GFI LanGuard version from one of the following links:
  2. After you download the installer, right-click on the installer > Properties > Unblock and apply before running the installation.
  3. Double-click the LanGuard installer and then go to the temp folder created, typically C:\Users\Logged on User\AppData\Local\Temp\LanGuard12Resources.
  4. Locate C:\Users\Logged on User\AppData\Local\Temp\LanGuard12Resources\LanGuard12Agent.msi
  5. Copy this file to ..\Program Files (x86)\GFI\LanGuard 12\Agent

Confirmation

After the above steps have been completed, run an agent scan or allow the system time to push the LanGuard Agent upgrade, at which point the remediation job should succeed.

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  1. Priyanka Bhotika

  2. Posted

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