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GFI EndPointSecurity Service Fails to Start Due to a Timeout

Overview

The GFI EndPointSecurity service does not start and returns one of the following timeout errors.

A timeout was reached (60000 milliseconds) while waiting for the GFI EndPointSecurity service to connect.

Error 1053: The service did not respond to the start or control request in a timely fashion.

If this error is encountered during the installation of GFI EndPointSecurity, the service does not start, and the installation is rolled back.

 

Root Cause

This issue may occur when the machine which EndPointSecurity is installed on does not have Internet access. When the service is started, the digital signature of esecservice.exe needs to be checked, and if this is not found in the CRL (Certificate Revocation List), a connection is made to Verisign.

 

Resolution

To resolve the error detailed previously, there are two possible solutions. Each of them is listed below:

Solution 1

Allow the GFI EndPointSecurity machine/user to access the Internet.

Solution 2

Disable Certificate Revocation List (CRLchecking for the GFI EndPointSecurity service user:

  1. Download the setreg tool.

  2. Login to the GFI EndPointSecurity Server using the GFI EndPointSecurity service user.

  3. Open the command prompt.

  4. Change the directory to the directory storing setreg.exe.

  5. Run the following command:

    setreg.exe 3 FALSE

    Note: The setting above can be reverted by running the following command:

    setreg.exe 3 TRUE

     

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  1. Priyanka Bhotika

  2. Posted

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