Start a conversation

Using Speed Test Reports Inaccurate Information

Overview 

When a customer wishes to examine their throughput or need to determine if there is any latency or problems with their network, they often turn to a third party speed test website to gauge just how fast their network is running and whether it is compliant to what it should be.

However, it can be found on any Exinda system where the optimizer is on and policies are created (perhaps by default using the wizard), that if a Speed Test is run, it gives an inaccurate value for both download and upload speed, usually much lower than expected.

This article provides a resolution to this issue.

 

Root Cause

Experiencing an inaccurate speed test can be the result of many different parts of the optimization engine doing what it is supposed to be doing. If a circuit is set for the full bandwidth coming into the network, it is possible for the following to have effects on a speed test:

  • The virtual circuit bandwidth where the Speed Test traffic is falling into is not set to use 100% of the bandwidth of the circuit.
  • There is a 'Web policy' which restricts web traffic bandwidth to less than 100% of the virtual circuit.
  • The network is laden down and as a result, there is no way to burst beyond the 'guaranteed' bandwidth percentage of the web policy

 

Resolution

It could be that the configuration is exactly as expected based on network rules. If this is the case, then the speed test will not run properly. It is quite common for example, for the web policy to be scaled down to use 1 to 10%. However, if this indicates a misconfiguration, these things can be changed.

To check if the optimizer is causing this problem with the speed test, it can be turned off while the speed test is run. If accurate data is generated, that means that there is some part of the optimizer that is throttling traffic, even if there doesn't appear to be.

If the results of this indicate a problem with your configuration, all these configuration changes can be made from Configuration > Optimizer.

  • If the Virtual Circuit bandwidth is not set to use 100% of the circuit bandwidth:
    1. Use the dropdown on the same line as the virtual circuit and select 'Edit'.
    2. Change the 'Virtual Circuit Bandwidth' to be 100%.

  • If the Web Policy is incorrectly configured in terms of how much bandwidth it is allowed to use:
    1. Click on the Web Policy name.
    2. Change the 'Guaranteed Bandwidth' and the 'Max (Burst) Bandwidth' to settings that are intended.

  • If the network is laden, then the only fix is to wait until a less busy time and retry the speed test.

If after examining your configuration, you do not see any noticeable improvements, contact Exinda TAC.

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments