Start a conversation

Users cannot access SMB file shares

Overview

In Accelerated scenarios, we have seen issues where users are unable access SMB file shares. When they try to access them, it would time out. There are various reasons as to why this could happen.
A few of them are below:

smbad[5852]: TID 139727403562752: [smbad.ALERT]: DB error: possible corruption - scheduling persistence clear
smbad[5852]: TID 139727403562752: [smbad.ALERT]: Cache clear will resolve database inconsistency, automatically restarting SMB acceleration

Cause

1. Users see the following in the logs. This means that SMB database is corrupt. It has to be reset.
smbad[5852]: TID 139727403562752: [smbad.ALERT]: DB error: possible corruption - scheduling persistence clear
smbad[5852]: TID 139727403562752: [smbad.ALERT]: Cache clear will resolve database inconsistency, automatically restarting SMB acceleration


To reset the database
a) Stop SMB service on all the Exindas involved in the process. This can be done under "System -> Setup -> Optimization -> Services
b) In the cli type in the following
en
conf t
acceleration smb cache clear
c) Start the SMB service on all the Exindas involved.

2. Some IPS/IDS systems mark SMB packets as
smb excessive padding exception
smb out of order block
This happens when these systems don't like the options Exinda adds to the packets for acceleration. This causes SMB connections to time out and not accomplish properly.
Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments