Overview
In Exinda Mobile version 4.3.1 users may encounter issues saying "disk space low - resizing"This causes the web interface of the EMS (Exinda Mobile Server) to be inaccessible
Caching may not work in these circumstances
Cause
The amount of disk space required for exinda mobile server to work is very less. The cache algorithm requires 600Mb free space to do its job. If the resident VM space is around this much, then the process wont be able to do it's job properly and will cause issues.Workaround
The solution is to increase disk space. If that is not possible, then this is the work around:The work around below tweaks the cache algorithm to use less disk space - lesser than 600 MB. This might cause some performance drawbacks - like slowness in the performance of caching.
apt-get remove --purge debian-faq poppler-data mutt w3m debian-faq wamerican debian-faq fonts-droid gsfonts groff exim4-base nano
apt-get autoremove
apt-get clean
Change the block store that is used to store cache data.
Modify /replify/proxy/xdr.app so that the following line
{block_store, block_store_bitcask},
Is replaced by
{block_store, block_store_lets},
Also, can you add the following entry to /replify/proxy/rprx.app
{disk_exceeded_threshold, {100, mb}},
This should be added in the env section of the configuration file. E.g. After the line:
{allow_netmasks_in_appservers, true},
This overrides the default disk threshold, which can be lowered as we are no longer using bitcask as a block store.
For these changes to take effect, run exinda-ctl restart.
Priyanka Bhotika
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