Answer
PROBLEM
QuarStoreFB Folder is growing in size or Logs.fdb is corrupt. Some error messages may occur:
- plugin [ContentSecurity.ML.QAS.Plugins.QAPlugin] threw an exception [Could not find file "D:\Program Files\GFI\ContentSecurity\MailSecurity\MiddleQueue\1260-1bf0-10e3bca0-000000000000001-000000000022279.rdt".]
- The GFI MailEssentials EmailSecurity Attendant Service service terminated unexpectedly. It has done this 1 time(s).
ENVIRONMENT
- GFI MailEssentials
- All supported environments
SOLUTION
- Stop all the GFI MailEssentials services and close the web user interface
- Make a backup of the file Logs.fdb from ..\GFI\MailEssentials\EmailSecurity\Data\ (for GFI MailEssentials 2014 R2 ..\GFI\MailEssentials\Attendant\data) and delete / rename the original file.
- Run the fdb creation tool by using LogsFDBCreator.exe from ..\MailEssentials\EmailSecurity\MiddleLayer (for GFI MailEssentials 2014 R2 and later ..\GFI\MailEssentials\Attendant\bin). Ensure that the firebird database logs.fdb is not present when you run the tool as it will otherwise fail to overwrite the existent firebird database.
- Re-start the GFI MailEssentials services
CAUSE
If the log files of the quarantine module is not created, the steps for deleting left over files are not considered completed. Creating the log file allows the processing / deletion process to complete and the files can get cleared out properly.
Priyanka Bhotika
Comments