Answer
PROBLEM
The GFI MailEssentials dashboard statistics for received messages is blank. The emails are counted, but the pie chart and bar graph show no data. This is a similar problem to when the quarantine shows missing sender and recipient information, and accompanies these errors:
"info ","RemotingHelper","Exception - I/O error for file CreateFile (open) 'C:\Program Files\GFI\ContentSecurity\MailSecurity\Data\LOGS.FDB';Error while trying to open file"
"error ","RemotingHelper","Error in InsertLogItem() - FirebirdSql.Data.Firebird.FbException: I/O error for file CreateFile (open) 'C:\Program Files\GFI\ContentSecurity\MailSecurity\Data\LOGS.FDB';Error while trying to open file ; at ContentSecurity.ML.Configuration.RemotingHelper.InsertLogItem(DateTime date, String sender, String recipient, String subject, String result, String guid)"
ENVIRONMENT
- GFI MailEssentials
- All supported versions
SOLUTION
- Stop all the GFI MailEssentials services and close the GFI MailEssentials WebUI
- Make a backup of the file Logs.FDB from ..\GFI\MailEssentials\EmailSecurity\Data\ (for GFI MailEssentials 2014R2 and later from ..\GFI\MailEssentials\Attendant\data), and delete / rename the original file
- Run the fdb creation tool by using the MiddleLayer from the ..\GFI\MailEssentials\EmailSecurity\ (for GFI MailEssentials 2014R2 and later from ..\GFI\MailEssentials\Attendant\bin) and double click on the file LogsFDBCreator.exe.
- Note: If the logs.fdb is present, the tool will not create database. Therefore, ensure that you rename or delete the original one as instructed in step 2.
- Restart the GFI MailEssentials services
CAUSE
The cause may come from corrupt data in the logs.fdb. Upgrade to the latest version of GFI Mailessentials, if it resolve the error.
Priyanka Bhotika
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