Start a conversation

Cannot Edit Rules Set by Rules Manager in Microsoft Exchange 2007 / 2010

Overview

Rules were set in Microsoft Exchange 2003 and the mailbox was migrated to a Microsoft Exchange 2007 or later server. The rules are not visible in junk mail or transport rules.

Environment

  • GFI MailEssentials
  • Microsoft Exchange 2007 or later

Root Cause

Microsoft Exchange 2007 and later do not show Messaging Application Programming Interface (MAPI) rules for each mailbox without a specialized tool.

Resolution

You can edit the rules in one of two ways:

  • Set up a 32-bit machine with MS Collaborative Data Objects (CDO) installed and use Rules Manager to remotely connect to your Microsoft Exchange 2007/2010 machine.
  • Use the Microsoft Foundation Class (MFC) MAPI editor provided by Microsoft to manually delete the rules. This involves logging into each mailbox where the rules are set. 
Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments