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GFI Archiver Mailbox Restore not working on a x64 platform

Answer

PROBLEM

GFI Archiver Mailbox Restore does not work on a x64 platform when Microsoft Exchange 2013 and GFI Archiver are running on separate machines. 

ENVIRONMENT

  • GFI Archiver
  • Microsoft Exchange 2013
  • Tested with:
    • Microsoft Outlook 2013 SP1 x86 installed on the same machine as GFI Archiver
    • Microsoft Outlook 2013 SP1 x64 installed on the same machine as GFI Archiver
    • NOTE: If exporting to Exchange 2013 on a separate host CDO/MAPI is required (Outlook is not sufficient in this scenario)

SOLUTION

Perform the following procedure to create a public folder mailbox and make MAPI work on Microsoft Exchange 2013 SP1 when GFI Archiver is not on the same machine.

On the Microsoft Exchange server:
 
Step 1: Allow user access to another user’s account with the following command:
Add-MailboxPermission -Identity "user001" -User Administrator -AccessRights Fullaccess -InheritanceType all
 
NOTE: Administrator is the person running the job while user001 is the user whose mailbox is being exported. 

Step 2: Ensure MAPI is enabled for that user:
Set-CASMailbox -Identity "Administrator" -MAPIEnabled $true

Step 3: Ensure a public folder accessible by the user is available (please refer to: http://technet.microsoft.com/en-us/library/jj651147(v=exchg.150).aspx). If no Public Folder is available, please create one and assign ownership. For example:
  1.  New-Mailbox -PublicFolder -Name MARPublicMailBox
  2.  New-PublicFolder -Name PublicFolder -Path \
  3.  Assign ownership to PublicFolder from the Exchange Admin Center (EAC) to the users
  4.  Enable Mail Settings
On the GFI Archiver server:
 
Step 4:  Open https://YourExchangeCASServer/OWA and add install the certificate to "Trusted Root Certificate Authorities"
 

If a MailboxRestore job is still not working after going through above:
  • Create a MAPI profile as outlined below (with Outlook installed):
    1. Go to Control Panel and select Mail {Need to set proxy server}
    2. Click Add
    3. Select Manual Setup
    4. Select Microsoft Exchange Server or compatible service
    5. Enter the server and click More Settings
    6. Go to connection and select Connect to Microsoft Exchange using HTTP
    7. Click on Exchange Proxy Settings
    8. Enter the server URL
    9. Select On fast networks, connect using HTTP first, then connect using TCP/IP
    10. Select Basic Auth for Authentication settings
  • Use MFCMAPI as a troubleshooting tool - to check if a MAPI connection to the target mailbox is possible in general

CAUSE

The connection to the target mailbox via MAPI fails.
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  1. Priyanka Bhotika

  2. Posted

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