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Unable to Approve from the GFI MailEssentials Quarantine and Items Are Blank

Overview

The user is unable to approve emails from the quarantine and the items are shown as blank. The ..\MailEssentials\Wwwconf\DebugLogs\Quarweb log contains the following error:

2013-04-29,10:13:36,607,1,"#00001B8C","#000006D1","error  ","QuarWeb","ERROR[P7]: System.IO.IOException: The file exists.
;Server stack trace:
;   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

Environment

  • GFI MailEssentials 
  • All supported environments

Root Cause

This problem may occur if the C:\Windows\Temp folder is full of temporary files. If you have more than 65535 files in the temp folder, the method GetTempFileName throws the mentioned exception error.

Resolution

Purge the C:\Windows\Temp folder.

Note: Getting an item count in the temp directory may take some time if the folder is full. To expedite the item count, perform the following:

To retrieve the item count in a directory or folder count using PowerShell, run the following command:

(Get-ChildItem C:\Windows\Temp -filter "*.*").Count

To retrieve the item count using the Command Prompt:

  1. Open a Command Prompt and navigate to C:\Windows\Temp.
  2. Run the following command:
    DIR /A | FIND "File(s)"
Choose files or drag and drop files
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  1. Priyanka Bhotika

  2. Posted

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