Overview
While opening GFI LanGuard's console or when synchronizing with Central Management Server (CMS) it is possible for a 503 error to appear. CMS runs using Microsoft Internet Information Services (IIS), making it prone to common http errors when hosting the website. The full error message is:
Error status 'ProtocolError', message 'The remote server returned an error: (503) Server Unavailable.'
This article demonstrates how to diagnose a 503 error along with the possible solution directions.
Prerequisites
Administrator access to IIS.
Diagnosis
The most common reason for the 503 error is an IIS Application Pool that was stopped or disabled while request generating the error was made. This can happen due to conflicts among websites already running in IIS, such as conflicting bindings, or the application pool credentials used are expired or no longer valid.
The Windows event log generally provides more information on possible reasons for this. To diagnose follow these steps:
- Navigate to Start > Run.
- Type
eventvwr.msc
in the textbox. - Expand the Windows Logs > Application.
- Locate the time frame of the attempted website or application pool start.
- Review the reported error in the Windows event logs.
- Try to reproduce the error by launching IIS and attempting to start the application pool, then opening the LanGuard console and forcing the synchronization by running a scan on the LanGuard server.
- Review the newly reported error in the Windows event logs and solve it accordingly based on the information from available Windows event logs.
Solution
While the LanGuard Central Management Server uses Microsoft IIS to run, we do not support troubleshooting IIS errors directly.
There are many possible solutions describing how to fix HTTP error 503: The service is unavailable, depending on the error found in the event logs. There are various posts on this topic, you can start with troubleshooting common IIS Errors.
Testing
Once the IIS error has been resolved, perform the steps below:
- Restart the GFI LanGuard Services.
- Clean cached data.
- Attempt console access/synchronization again.
Priyanka Bhotika
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