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Handling Error "The patch management database is unavailable"

Overview

When viewing the scan results from an Agent Scan or an Interactive/Scheduled Scan, the following error occurs:

"The patch management database is unavailable."

This article provides step-by-step instructions on how to resolve the above error.


Environment

GFI LanGuard


Root Cause

The agent or server has not been able to complete a software update session since its installation and therefore has not been able to create the Patch Management database lanss_xx_patchmngmt.mdb (xx represents the version of LanGuard installed).


 

Resolution

 

Agent Scan

  1. Verify if the Patch Management database exists:

    1. Navigate to C:\ProgramData\GFI\LanGuard 12\PatchManagement\.

    2. Check if the lanss_xx_patchmngmt.mdb file is present or missing.

  2. Go through the article 'LanGuard Agent's Status Is Listed as 'Unable to Contact Server' in the Console' to check the agent's ability to connect to the LanGuard Apache Communication Server.
  3. From the Agent/Relay Agent:

    1. Open Internet Explorer.

    2. Type in the URL as per the following syntax (replace the LanGaurdServerIP and port numbers with the actual values as per the existing setup):

      Default Ports are 1070 (v11 and previous) or 1072 (v12 or later). If need be, these can be changed.

      http://LanGuardServerIP:Port/files/update/wsusscn2.cab

      For example http://192.168.1.200:1072/files/update/wsusscn2.cab

      Note: Do not substitute the hostname for the IP address. LanGuard uses IP addresses to connect to the server for this component.
    3. Download the file and verify if the download completed successfully.
      If the download is unsuccessful, then there is likely an issue in the client's networking environment, which is out of scope for LanGuard support. Follow the steps mentioned in the "Ensure That Machine Names Resolve via NSLookup" section of the "Testing Network Connectivity and Security Permissions for GFI Software Security Products" article. If the NSlookup does not resolve the issue, review Network and DNS settings to correct the networking issue. If need be, contact LanGuard Support to troubleshoot the issue further.

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Interactive or Scheduled Scan (Console Scan)

  1. Verify if the Patch Management database exists: 

    1. Navigate to C:\ProgramData\GFI\LanGuard 12\PatchManagement\.

    2. Check if the lanss_xx_patchmngmt.mdb file is present or missing.

  2. Attempt a program update and check if any of the files get downloaded from the GFI Update Servers.

  3. If the update fails to download files, check the access to GFI Servers:

    1. Open the web browser on the machine hosting the GFI LanGuard Console.

    2. Try to access the GFI Software Updates Site.

    3. If you are unable to access this site, your network administrator may be blocking access with a web filter. Request an exception for *.gfi.com.

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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