Answer
Problem
Unable to update Bitdefender engine with message “download failed”.
The Event Viewer application logs show the following error:
Failed to update Engine Bitdefender: System.Net.WebException: error from remote server (416) Requested Range Not Satisfiable.
Environment
- GFI WebMonitor build: 20151019
Solution
The solution for this problem consists of two steps:
Step 1: Disable proxy caching:
- Open the GFI WebMonitor interface
- In the main menu click the
icon
- Go to Settings > Advanced Settings > Proxy Settings
- Click Caching.
- Set Enable Caching to Off.
Step 2: Clear proxy cache data
- Close the GFI WebMonitor interface
- Go to Start > Run > Services.msc
- Stop the following services:
- GFI Proxy Service
- GFI WebMonitor Core
- Browse to <GFI WebMonitor installation path>\GFI\WebMonitor\HttpCache
- Clear the proxy cache data stored in the HttpCache folder.
- Start the services stopped on step 3.
- Open GFI WebMonitor interface.
Cause
The proxy cached data is corrupt. By disabling and clearing the old proxy cached data the download will start successfully updating the security engines.
Priyanka Bhotika
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