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SMTP Logs are not written even if the IIS logging is activated and there is mailflow

Answer

PROBLEM

SMTP Logs are not written, even if the IIS SMTP W3C Logs are enabled and there is mail flow.


ENVIRONMENT

  • All supported environments
  • Microsoft Windows 2008 and HIGHER
  • IIS SMTP


SOLUTION

Please ensure that the IIS SMTP- Logging is enabled and configured as per Microsoft knowledge base. By default this is not activated within IIS Manager.Please ensure that the IIS and SMTP services are running. Check whether the logs are written successfully into the smtpsvc folder configured within IIS.

If there are no log files, then ODBC Logging Module might be missing and needs to be installed:
  • Go to Administrative Tools and open the Server Manager 
  • Click on Roles and select Web Server (IIS)
  • Go to Role Services and clcik on Add Role Services
  • In the Wizard select ODBC Logging under Health and Diagnostics
  • Click Next and Install
  • On the Results page, click Close
 
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CAUSE

The SMTP service logging is dependant to the ODBC Logging module which needs to be installed.
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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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