Answer
PROBLEM
Experiencing persistent or intermittent failures with outbound faxes due to the fact that the gateway is not sending the T.38 invite or responding with the correct command to complete switching over to the T.30 protocol.ENVIRONMENT
- GFI FaxMaker
- all supported environments
SOLUTION
Once an outbound fax is captured with Wireshark: In a successful outbound fax call over T.38, the switch over from SIP/H245 to t38:t30 occurs as shown in the screenshot below for H.323):If the fax call does not switch over to T.38, please follow the steps below:
- Stop the GFI FaxMaker Fax Server service
- Open the Dialogic Brooktrout Configuration Tool in advanced mode (Click Advanced Mode button if wizard starts up)
- Click on SIP or H.323 (depending on what protocol is being used) under IP Call Control Modules
- Click on the T.38 parameters tab
- Set Media Renegotiate Delay Outbound, msec to 4000 (you can try different values if needed).
- Click on Save and Apply at the top of the configuration tool.
- Close the Dialogic Brooktrout Configuration Tool and re-start the GFI FAXmaker Fax Server service
Please note that this is approach is only a workaround and should not be handled as a best practice. The root of the issue is caused by a missing configuration part of the gateway that communicates directly with the Dialogic Brooktrout SR140 .
CAUSE
The Dialogic Brooktrout SR140 waits for the T.38 invite message if it is set to T.38 only. If no T.38 invite comes from the gateway, or if we are waiting for the gateway to send us some command to switch over, then the Dialogic Brooktrout SR140 can be configured to send the invite instead. The issue is caused by the equipment used for the gateway and not by the Dialogic Brooktrout SR140.Note
- Dialogic no longer supports any SDK prior to 6.7.0 (Included with GFI FaxMaker 2014)
- Microsoft Windows Server 2003 is supported by GFI FaxMaker but IS NOT supported by Dialogic for SDK 6.7.0
Priyanka Bhotika
Comments