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Clearing NIC Tx/Rx Statistics

Summary

When viewing NIC diagnostics under the 'System > Network, "NICs" page or the System > Diagnostics, "NICs" page, there will be an interface level set of diagnostics run on the interface. It is difficult to clear this information out of the system and any option on the UI or CLI will not get rid of the statistics.

Overview

The NIC diagnostics are a valuable tool that can be run on the Exinda in order to show a list of the network cards, each port and statistics for each of them, including the following:
  • Transferred (Tx) bytes
  • Received (Rx) bytes
  • Tx / Rx errors
  • Dropped packets
  • Errored packets
  • Cyclic Redundancy Failure (CRC) notifications
These statistics can be used to determine whether an interface is operating correctly and whether there are any errors on the interfaces that are indicative of a bad port or other hardware issues. These can also be used to monitor traffic at a base level without invoking the Exinda firmware. Most of the time, these diagnostics are unnecessary to check day to day, but they are useful when things are not operating optimally.

Sometimes, it is wanted to clear these statistics in order to zero them out and get a clean slate after a known network problem that generate errors or other packet loss.

When using the web UI, under System > Setup, "Monitoring" tab, there is an option to "Clear Interface Statistics", among other types. When doing this in an attempt to clear the NIC statistics, it is noticed that these NIC statistics are not cleared like would be assumed. Similarly, there is no command line option that also works to clear the NIC statistics in order to zero them out at any time.

Cause

The NIC diagnostic statistics are generated on a driver level, and are independent of the Exinda firmware. Unlike switches and routers, where this information is integrated into the core firmware (for example, the 'show interfaces' command on most switches is comparable to the NIC diagnostics in the Exinda, but are more heavily integrated into the firmware), the Exinda simply utilizes its own mechanisms for tracking. It studies these diagnostics and utilizes them for other statistics, but it does not generate them itself, as it is the driver's responsibility.

The Exinda doesn't have a mechanism built into both the web UI and CLI to be able to clear these statistics. The "Interface Statistics" clearing option available, instead clears the database information for the 'Interfaces' graph available for viewing. This doesn't clear the NIC level statistics, simply what the firmware has collected from them and placed in its database. Though the wording is confusing, because 'interface' could refer to both of the options. For clarity, the diagnostics are referred to as 'NIC' diagnostics due to the relation of the hardware level.

Resolution

These statistics are cleared upon a reboot of the device; everything is zeroed out. If it is necessary to clear the statistics as to now skew results if there were known tests or known problems on the network, simply rebooting the appliance will get rid of this information to start fresh.

Internal Notes

The diagnostics are a basic "ethtool -S [interface]" with a few other flags.
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  1. Priyanka Bhotika

  2. Posted

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