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MailEssentials | Installer not running or showing any activity

Summary

When running the installer, the window never opens

Overview

When running the MailEssentials installer, the window never opens.
There are different scenarios when this can happen, all of which have been identified as environmental.

Cause

  • Standalone AntiVirus
  • .NET 4.5 missing or 3.5 corrupt
  • Blocked installer
  • UAC enabled
  • Requirements not met
  • System file corruption

Resolution

AntiVirus

A strong indication that the execution is blocked, is when the install window doesn't open, but task manager shows that the process is running with less than 1MB of memory.
For example when we run mailessentials.exe, we would see "mailessentials.exe *32" as an entry in task manager.
Task manager showing ME process:
ME process

Same behavior might be observed when trying to launch other GFI installations or non-GFI installations. This is known to happen with Symantec EndPoint in particular.
Terminate the process, disable the AV, then rerun the installer.

.NET 4.5 missing or 3.5 corrupt

If no AV is present, but the installation still doesn't seem to do anything, then we would check the install log.
There are 2 install logs, but since the window doesn't open, we will only find one, located in the %tmp% folder. Example:
C:\Users\Administrator.WIN-PN4CRENPNCC\AppData\Local\Temp\

Locate the file in question:
gfimes_20180301163112.log, corresponds to gfimes_<yyyy><mm><dd><hh><mm><ss>.log

If the file is less than or around 100 lines, and you see the following:

[347C:30B0][2018-03-01T11:07:32]i000: Setting string variable 'WixBundleManufacturer' to value 'GFI Software Development Ltd.' 
[347C:30B0][2018-03-01T11:07:34]i000: Loading managed bootstrapper application. 
[347C:30B0][2018-03-01T11:07:34]e000: Error 0x80131522: Failed to create the managed bootstrapper application. 
[347C:30B0][2018-03-01T11:07:34]e000: Error 0x80131522: Failed to create UX. 
[347C:30B0][2018-03-01T11:07:34]e000: Error 0x80131522: Failed to load UX. 
[347C:30B0][2018-03-01T11:07:34]e000: Error 0x80131522: Failed while running 
...
[347C:30B0][2018-03-01T11:07:34]e000: Error 0x80131522: Failed to run per-user mode. 
[347C:30B0][2018-03-01T11:07:34]i007: Exit code: 0x80131522, restarting: No


First thing is to ensure that the user that is trying to install the product is part of the domain admin group and is not a local administrator.
If the above is not the case, then it's a strong indication that .NET 4.5 is missing or 3.5 is corrupt. Either way, MailEssentials requires 4.5 (https://www.microsoft.com/en-us/download/details.aspx?id=30653). Install 4.5, then rerun the installer

Other possibilities

Choose files or drag and drop files
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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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