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Personal whitelist or blacklist is not updated when approving emails with a SPAM tag

Answer

PROBLEM

When trying to approve selected emails, the personal whitelist or blacklist is never updated.
 
Locate the log from the Server in ..\GFI\MailEssentials\wwwconf\debuglogs Log Name ClientAccessService.log and you may find the following error:

error  ","ClientAccessService","Error: AddToPersonalBlocklist...FAILED! Unable to load the native components of SQL Server Compact corresponding to the ADO.NET provider of version 8080. Install the correct version of SQL Server Compact. Refer to KB article 974247 for more details."

ENVIRONMENT

  • GFI MailEssentials
  • All Supported Environments

SOLUTION

Follow the steps from the KB article from Microsoft and re-install SQL Compact Edition: http://support.microsoft.com/kb/974247

CAUSE

Possible corruption during the upgrade process or missing components of the SQL Compact Edition installation.

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  1. Priyanka Bhotika

  2. Posted

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