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Emails Passing Through a Secondary SMTP Server Are Being Blocked

Overview

The GFI MailEssentials machine has two (2) Simple Mail Transfer Protocol (SMTP) Virtual Servers. GFI MailEssentials is bound to the Default SMTP Virtual Server; however, emails configured to pass through the secondary SMTP Virtual Server are still scanned and are sometimes blocked as spam.

Environment

  • MailEssentials
  • All supported environments

Root Cause

This issue may occur if the secondary SMTP Virtual Server is added after GFI MailEssentials was installed. This causes all properties from the original SMTP Virtual Server, including the GFI MailEssentials sinks, to be replicated to the secondary server. Thus, causing all emails from both SMTP Virtual Servers to be scanned.

Resolution

  1. Open the GFI MailEssentials Configuration.
  2. Browse to the General > General Settings > Settings.
  3. Click on the Bindings tab to list all the available SMTP servers.
  4. Bind GFI MailEssentials to secondary SMTP Virtual Server (the SMTP Virtual Server for which you do not want GFI MailEssentials to filter emails) and click on Apply (This will clear the sinks from the primary SMTP Server).
  5. Bind GFI MailEssentials back to the primary SMTP server and click on Apply.
  6. At this point, the sinks should only be registered with the primary SMTP Virtual Server and therefore Anti-spam filtering will only be performed for emails passing through this virtual server.
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  1. Priyanka Bhotika

  2. Posted

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