Start a conversation

Cannot Generate Report with MailInsights

Overview

This article describes the issue, and its resolution which occurs when MailInsights reports cannot be generated and the following errors appear in the debug logs:

MIReportManager.log:
"info ","MIReportManager","Report saved. Now sending email." 
"error ","MIReportManager","Error: Failed to get writer lock in AddReport() - MArc.MailInsights.MailInsightsException: EmailNotAvailable 
; at MArc.MailInsights.CommonOptions.GetCommonRepOptions(Report rpt) 
; at MArc.MailInsights.ReportManager.AddReport(String userGuid, Report report)" 


MIScheduler.log:
"error ","MIScheduler","Error: Failed GetCommonRepOptions. MArc.MailInsights.MailInsightsException: EmailNotAvailable 
; at MArc.MailInsights.CommonOptions.GetCommonRepOptions(Report rpt) 
; at MArc.MailInsights.MIScheduler.GenerateReport(User usr)"

Environment

  • GFI MailArchiver 2013 R2 or older
  • All supported environments

Root Cause

MailInsights reports are sent to the user that is currently logged into GFI MailArchiver. The user who was logged into GFI MailArchiver with a user account that does not have an email address assigned.

Resolution

Log into the GFI MailArchiver web interface with a user that has an email address assigned to him in Active Directory (the mail field must have a value).

Confirmation

Once you have logged in with a valid email address, request the report again.

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments