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Error 'The application could not open the database' when using the GFI LanGuard console

Answer

PROBLEM

When GFI LanGuard cannot access its backend database using the console, the following error is shown: 'The application could not open the database!'


ENVIRONMENT

  • GFI LanGuard
  • Microsoft SQL server
  • All supported environments


SOLUTION

  1. Confirm general connectivity to the database by performing a general connection test
  2. Confirm the drive storing the SQL database and log file has sufficient space
    1. Open Microsoft SQL Server Management Studio
    2. Right-click the LanGuard database (LNSSScanResults*) > Properties
    3. Select Files page
    4. Under Database files: find the Path of database and log files
    5. Using My Computer, confirm drive from step 4 has sufficient space
      • If limited space
        • Free space by deleting  unneeded files
        • Move SQL database and log file to another drive with more space
  3. Confirm the Autogrowth settings allow the database and log file to grow
    1. Open Microsoft SQL Server Management Studio
    2. Right-click the LanGuard database (LNSSScanResults*) > Properties
    3. Select Files page
    4. Under Database files: > Autogrowth
    5. Select User-added image for database file
      1. Confirm set to Unrestricted File Growth
    6. Select User-added image for log file
      1. Confirm set to Unrestricted File Growth


CAUSE

There is a general connectivity problem, either the drive storing the SQL database and log file is out of space or the autogrowth settings do not allow files to grow.
Choose files or drag and drop files
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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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