Answer
PROBLEM
When GFI LanGuard cannot access its backend database using the console, the following error is shown: 'The application could not open the database!'
ENVIRONMENT
- GFI LanGuard
- Microsoft SQL server
- All supported environments
SOLUTION
- Confirm general connectivity to the database by performing a general connection test
- Confirm the drive storing the SQL database and log file has sufficient space
- Open Microsoft SQL Server Management Studio
- Right-click the LanGuard database (LNSSScanResults*) > Properties
- Select Files page
- Under Database files: find the Path of database and log files
- Using My Computer, confirm drive from step 4 has sufficient space
- If limited space
- Free space by deleting unneeded files
- Move SQL database and log file to another drive with more space
- Confirm the Autogrowth settings allow the database and log file to grow
- Open Microsoft SQL Server Management Studio
- Right-click the LanGuard database (LNSSScanResults*) > Properties
- Select Files page
- Under Database files: > Autogrowth
- Select
for database file
- Confirm set to Unrestricted File Growth
- Select
for log file
- Confirm set to Unrestricted File Growth
CAUSE
There is a general connectivity problem, either the drive storing the SQL database and log file is out of space or the autogrowth settings do not allow files to grow.
Priyanka Bhotika
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