Start a conversation

GFI Archiver not archiving emails

Overview

If you see that user emails are not archiving, emails are stuck in the Microsoft Exchange journal mailbox or the Archive Store summary shows that emails or files have not been archiving then you should follow the steps below to verify settings, access and components are set to allow mail to be archived.

 

Diagnosis

 

Emails and Files may not be archived due to database failures or low disk space.

Archiver stops archiving for one or more domains and rebooting doesn't help. 

GFI Archiver could stop archiving messages and files for domain connectivity issues, incorrect configuration, out of date database schema, large emails in the journal mailbox or interference of third party anti-virus software.

NOTE: To confirm emails are not being archived, from GFI Archiver, navigate to Configuration > Archive Stores > click Summary of active archive store > Check Last Email Archived On.

 

SOLUTION

 

General Verification

  1. Confirm GFI Archiver is able to connect to journal mailbox and connection is active
    1. From GFI Archiver, navigate to Configuration > Mail Servers to Archive > select Journal Mailbox > click Edit > complete wizard and verify test is successful
    2. Ensure journal mailbox is set to Active
  2. Confirm GFI Archiver is able to connect to back end database
    • From GFI Archiver, navigate to Configuration > Archive Stores > select active archive store > click Edit > complete wizard and verify test is successful
      • If using Microsoft SQL Server, we recommend using the SA account
        NOTE: At minimum an account with DB Owner rights is required
  3. Confirm the number of Mail Enabled Users does not exceed Licensed Users
    • From GFI Archiver, navigate to Configuration > General > Change License Key
  4. Check the number of files in  ..\GFI\Archiver\Core\Pickup and ..\GFI\Archiver\Core\Queue
    • Having items in these folders is normal but items should pass through these folders quickly
    • If no items are appearing in this folder refer to Troubleshooting issues with Journal Mailbox
    • If there are files stuck in these folders or the same item is reprocessing continuously 

Troubleshooting issues with Journal mailbox

Troubleshooting databases

  • Confirm active archive store database size does not exceed recommended size limit, from GFI Archiver, navigate to Configuration > Archive Stores > click Summary of active archive store
      • Microsoft SQL Server 2008 Express edition has a database size limit to 4GB
      • Microsoft SQL Server 2008 R2 Express edition has a database size limit to 10GB
      • Microsoft SQL Server 2012 Express edition has a database size limit to 10GB
      • Microsoft SQL Server 2014 Express edition has a database size limit to 10GB
      • Microsoft SQL Server 2016 Express edition has a database size limit to 10GB
      • Microsoft SQL Server Standard Edition has an upper limit of 524 Petabytes
      • Firebird 2 GB
    NOTE: Firebird Databases are recommended for evaluation purposes only
  • Ensure Best practices for GFI Archiver are being followed
  • Ensure antivirus software is not scanning GFI directories
  • If using Microsoft SQL Server databases
    • Ensure that GFI Archiver has a stable connection to Microsoft SQL server and that Microsoft SQL Server has enough resources to cope with the load
    • Run a scan to check for hard disk errors using Microsoft chkdsk
    • Run an integrity check on the problematic GFI Archiver database
    • Ensure that the timeout values from Microsoft SQL Server itself (including connection timeout) are set to a high value (not the default of 2 minutes)
    • Ensure that the autogrowth of the DATA and TRANSACTION LOG are set to a fixed size (not percentage) and ensure that the database has enough space to grow automatically

If only certain emails are not being archived:

  • Check Configuration > Archive Restrictions and remove any conflicting rules
  • Check Configuration > Archiving Scope and verify the type of mail is selected for Archiving
  • Check Configuration > Retention Policies and verify the 
  • Confirm that journaling is enabled for all Microsoft Exchange databases and working correctly in Microsoft Exchange

 

Testing

 

After verifying the settings are in place and mail should be flowing from GFI Archiver, navigate to Configuration > Archive Stores > click Summary of active archive store > Check Last Email Archived On. The date should be updated and show the current time if the archiving functionality has been restored.

If errors are still occurring Gather Troubleshooting Logs, provide information on what type of Journal Mailbox is configured as well as the type of database in use. Additionally, if files are stuck in the Archiver Queues if you are able to release a copy, Zip the suspected files and provide them with the troubleshooting logs for review. 

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted
  3. Updated

Comments