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Error: 'Unable to install updates' While Running Program Updates

Overview

While checking for Program Updates, the updates are downloaded successfully; however, the following error displays during the installation process.

Unable to install updates.

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This error is usually caused due to old updates. This article explains how to clear the old updates to download a fresh copy. To perform the process, you can choose one of the following methods:

 


 

Information

Environment

  • GFI LanGuard 2012 and higher.

 

Root Cause

The most common root cause of this error is that there is no sufficient drive space available for the updates.

 


 

Process

Method 1: Step-By-Step Instructions

  1. Make sure the Scanning Profiles Editor is not open.
  2. Go to Start > Administrative Tools > Services.
  3. Stop the GFI LanGuard Attendant Service.
  4. Delete all the files except the following in the Update folder: C:\ProgramData\GFI\LanGuard 12\Update\
    DO NOT delete the entire Update folder and the files below:
    • updatehistory.xml
    • saccess.sql
    • ssqlserver.sql
    • toolcfg_maintenance_90.xml
    • toolcfg_maintenance_102.xml
    • toolcfg_maintenance_103.xml
    • toolcfg_maintenance_104.xml
    • toolcfg_maintenance_110.xml
    • toolcfg_maintenance_111.xml
    • toolcfg_maintenance_112.xml 
  5. Start the GFI LanGuard Attendant Service in the Services window.
  6. On the GFI LanGuard console, go to: Configuration > Program Updates > Check for updates > Next.
  7. Select the option Update ALL files (including the ones already updated) on the bottom left corner.
  8. Click Next.

    2019-07-01_8-12-55.png
  1. Wait for the process to complete and press Finish.
  2. Restart the GFI LanGuard Attendant Service.
  3. Go to Activity Monitor > Program Updates Activity to check the last update information to confirm no errors.

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Method 2: PowerShell Instructions

  1. Open PowerShell as an administrator on the GFI LanGuard server.
    1. Right-click on Windows PowerShell > Run as administrator.
    2. Once open, make sure the title bar displays: Administrator: Windows PowerShell
  2. Run the following commands:
    1. Get-process *scanprofiles*|stop-process -force  
    2. Get-service *lanss*|stop-service -force
    3. Get-ChildItem -Path 'C:\ProgramData\GFI\LanGuard 12\Update'-Recurse -Exclude updatehistory.xml,msaccess.sql,mssqlserver.sql,toolcfg_maintenance_102.xml,toolcfg_maintenance_103.xml,toolcfg_maintenance_104.xml,toolcfg_maintenance_110.xml,toolcfg_maintenance_111.xml,toolcfg_maintenance_112.xml,toolcfg_maintenance_90.xml|Remove-Item -Force  get-service *lanss*|start-service
  3. On the LanGuard console, go to Configuration > Program Updates > Check for updates > Next.
  4. Select the option Update ALL files (including the ones already updated).
  5. Wait for the process to complete and press Finish.
  6. Run the following command to restart the service:
get-service *lanss*|restart-service -Force

 

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  1. Priyanka Bhotika

  2. Posted

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