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The Wmiproc.Exe Process Is Not Starting on Windows XP

Overview

Agent scans from Windows XP computers might not contain data (e.g., motherboard information) as LanGuard fails to run wmiproc.exe.

To validate the issue, do the following steps:

  1. Verify that the agent is running on Windows XP.
  2. Collect a set of Troubleshooting files from the agent that covers a scan.
  3. From the lanss_v102_securityscanner.csv file, the following messages are logged:

    2012-03-06,15:41:53,889,3,"#00000798","#00000a48","info ","WmiOP","WmiProc command line "C:\Programme\GFI\LanGuard 10 Agent\wmiproc.exe" 15363129910.144.181.11."
    2012-03-06,15:41:53,951,1,"#00000798","#00000a48","error ","WmiOP","Could not create external WMI operational process "C:\Programme\GFI\LanGuard 10 Agent\wmiproc.exe" 15363129910.144.181.11. CreateProcessAsUserW error 6. Quitting."

 

Environment

LanGuard 2011 SR2 build 20111128

 

Root Cause

This is a product defect which has been resolved in LanGuard 2012.

 

Resolution

Please upgrade to LanGuard 2012 to resolve this issue. If an an upgrade is currently not feasible, you can run an interactive/scheduled scan as a workaround.

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  1. Priyanka Bhotika

  2. Posted

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