Overview
GFI LanGuard fails to install or upgrade with the following error message:
Error 0x80070002
Environment
- GFI LanGuard 9.0
Root Cause
The previous GFI LanGuard installation failed to remove all the old registry keys.
Resolution
Note: Please perform a backup of the registry prior to applying any changes.
- Delete the GFI LANguard NSS Service in HKLM\System\CurrentControlSet\Services\gfi_lnss9_attservice
- Delete the product name from Add/Remove Programs: go to HKLM\Software\Classes\Installer\Products\<GUID> and click on each GUID and look for the one corresponding to
ProductName=GFI LANguard 9.0.
- Delete the GFI LANguard NSS MSI uninstall key: go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{<ProductGUID>} and click on each GUID and look for the one corresponding to
ProductName=GFI LANguard 9.0.
- Delete the GFI LANguard N.S.S InstallShield uninstall keys:
- Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{<ProductGUID>} and click on each GUID and look for the one corresponding to
ProductName=GFI LANguard 9.0.
- Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield Uninstall Information\{<ProductGUID>} and click on each GUID and look for the one corresponding to
ProductName=GFI LANguard 9.0.
- Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{<ProductGUID>} and click on each GUID and look for the one corresponding to
- Delete the GFI LANguard NSS key located in HKEY_LOCAL_MACHINE\SOFTWARE\GFI\LNSS9
- Delete the per-user keys:
- In the registry editor open HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData. Here you will find one or more nodes with the user's SID. For example, the Administrator's would be
S-1-5-18
. - Under each user SID listed, expand it down to the Products > <GUID> > InstallProperties and look for the <GUID> that contains the
DisplayName
property value ofGFI LANguard 9.0.
- Delete the <GUID>.
- In the registry editor open HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData. Here you will find one or more nodes with the user's SID. For example, the Administrator's would be
- Reboot the server.
- Delete the GFI LANguard NSS directory.
Priyanka Bhotika
Comments