Start a conversation

Unable to Install Second Instance of LanGuard Using the Same Database

Overview

This article will be used when you're unable to install the second instance of LanGuard using the same database without viewing the data from the first instance.

Corresponding support articles.

Environment

  • GFI LanGuard.
  • All Supported versions.

Root Cause

Using the same LanGuard database for two or more instances is not supported. For example, when an issue with the database occurs and the database gets corrupt all the LanGuard instances will be stopped in order for troubleshooting to be done. The performance will also decrease while using one database only. Therefore it is not recommended and supported to use a single database.

Note: The second instance of GFI LanGuard installation can enter the same database name that is already used by the first instance. Doing so will list the same information. Database corruption can occur if you start a scan for the same machine on both LanGuard instances

Resolution

  1. From LanGuard 12.3 version, specify a custom database name during the installation process.
  2. Create a new database by typing a different database name and proceed to install GFI LanGuard on the second server.
  3. It is recommended to install GFI Central Management Server in order to track all the GFI LanGuard instances and sites for all installed and missing patches.
  4. Install the second instance of GFI LanGuard on a second server with a different database name.

Confirmation

After installing the GFI Central Management Server and following the above steps, you will be able to install the second instance of LanGuard with a different database name.

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments