Overview
When deleting Scan Results from GFI LanGuard, the following error is displayed:
Some Scans were not deleted due to database integrity restrictions!
Possible solution: Delete the computer instead.
Possible solution: Delete the computer instead.
Environment
Microsoft SQL 2005 or newer
Root Cause
In GFI LanGuard, a computer snapshot or the information about a computer at a specific moment may be composed of information from more than one scan.
For instance, you could run a Missing Patches scan and then a System Information scan. The computer snapshot composes info from those two scans, each covering a certain specialized area.
For instance, you could run a Missing Patches scan and then a System Information scan. The computer snapshot composes info from those two scans, each covering a certain specialized area.
That message shows up when you try to delete a scan that is a contributor to the snapshot of a computer. Once a new scan takes place that brings fresh data, the old scan can be deleted.
Resolution
There are two possible solutions for this:
Solution 1:
- Run a full scan on the machine member of the Scan Result.
- After this, you should be able to delete the previous Scan Results.
Solution 2:
- Remove the machine from the GFI LanGuard console.
- Delete the Scan Results in question.
- Add the machine in GFI LanGuard again.
Priyanka Bhotika
Comments