Summary
When using Exinda Mobile, Client Matching Rules can be set up to allow conncetions from Mobile Clients (and disallow connections, if required). Sometimes these rules can stop workingOverview
Exinda Mobile Manager is a solution to allow remote clients to benefit from WAN acceleration to their 'home bases' so that their connections can still be fast. To help perform this, the Exinda Mobile Manager allows the creation of 'Client Matching Rules', which will allow clients to connect to specific Exinda Mobile Servers and allow these servers to accept or deny the connection based on what Client Matching Rules it has.Sometimes it has been seen that when applying these Client Matching Rules, it is possible for the rules to start failing without any user intervention (no changed information, no reconfiguration, etc).
Cause
The cause is currently unknown, but has to do with a file in the Exinda Mobile Manager, which runs the server. This file is called rem_client_handler.beam and is a criticial part to how the Client Matching Rules work.Workaround
Setting a Exinda Mobile Server to use a Client Matching Rule of 'All' will fix this problem. However, it also comes with the drawback of allowing connections from all IP addresses, regardless of what administrators might want.Resolution
The resolution is to contact TAC; if it is determined that this problem occurs, TAC will need to work to replace this file properly.Internal Notes
Commands in bold.1. Log into the shell (root/default)
2. Navigate to /replify/em/ebin
a. cd /replify/em/ebin
3. Backup the file /replify/em/ebin/rem_client_handler.beam on the Mobile Manager (EMM).
a. cp /replify/em/ebin/rem_client_handler.beam /replify/em/ebin/rem_client_handler.beam.backup
4. You will need a new rem_client_handler.beam file. This file is on our NAS as of Oct 19, 2016. \\nas-01\software\Exinda_Mobile\New rem_client_handler
It will need to be copied over to the user's EMM
4. Restart the EMM using exinda-ctl restart.
Priyanka Bhotika
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