Answer
PROBLEM
The GFI MailEssentials custom blocklist takes long to load
ENVIRONMENT
- GFI MailEssentials
- All supported environments
SOLUTION
It is recommended to limit the amount of entries in the GFI MailEssentials blocklist to 10,000. Rather then using a lot of entries in the custom blacklist, GFI Software recommends using the DNS blocklists which are being constantly updated with the IP addresses used by spammers to send their emails.
CAUSE
This issue usually occurs when users send their SPAM emails to the Add to blocklist folder. Users should be encouraged to only send emails to this folder when they receive emails repeatedly from the same address. They should use the This is SPAM email folder. This has the benefit of blocking similar mails as spam which are also received from other spammers.
Priyanka Bhotika
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