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Vulnerability Scan Failure: Not enough storage is available to complete this operation

Overview

 

When running the GFI LanGuard Vulnerability Scan, you might encounter the following error: 

2019-12-18,12:11:07,846,1,"#00006720","#00005894","error ","MissingPatch","TMicrosoftUpdateGetterUsingOnlyWURemoteOrLocal.GetUpdates - Getting info about updates EOleException Error EOleException: 'Not enough storage is available to complete this operation'

This error indicates a space or memory utilization issue on the device. This article provides the steps on how to resolve the error when GFI LanGuard Vulnerability Scan fails.

 


Root Cause

 

The error is generally related to the call to the Windows Update Agent (WUA) engine to extract the wsusscn2.cab data for the detection of Microsoft missing patches. The WUA engine fails to respond and reports the memory storage error.

 


Resolution

 

Below are five possible solutions that you can run on the GFI LanGuard server. After completing the applicable solution, run the scan to see if it resolves the issue:

  1. Running the scan when the device is not in use

  2. Deleting files from Windows' temporary directories

  3. Optimizing memory configuration

  4. Increasing the Windows pagefile virtual memory size

  5. Applying Microsoft Windows KB3050265 update

Note: If the issue persists after applying these steps on the server, repeat the steps on the client machine experiencing this issue.

 


Solution 1: Running the Scan When Device Is Not in Use

 

Change the scan runtime when the device is not in use.

Example: Perform the scan at night when the device's resource utilization is at its lowest.

 

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Solution 2: Deleting Files from Windows' Temporary Directories

 

  1. Clear the following directories: 
  • C:\Windows\Temp

  • C:\Temp

  • %TEMP%

  1. From the GFI LanGuard Dashboard, right-click on the device and go to Patch Management > Re-run Vulnerability Scan.

 

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Solution 3: Optimizing Memory Configuration

 

  1. Stop the GFI LanGuard Attendant Service.

  2. Open the Run dialog box. Type regedit and click the OK button to launch the Registry Editor.

  3. Create a backup of the registry.

  4. Navigate to HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\MemoryManagement\LargeSystemCache and set its value to 1.

  5. Navigate to HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size and set its value to 3.

  6. Save all changes. 

  7. Restart the machine. 

  8. From the GFI LanGuard Dashboard, right-click the device and go to Patch Management > Re-run Vulnerability Scan.

 

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Solution 4: Increasing the Windows Pagefile Virtual Memory Size

 

  1. Refer to online resources on how to perform this for your environment.

  2. From the GFI LanGuard Dashboard, right-click on the device and go to Patch Management > Re-run Vulnerability Scan.

 

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Solution 5: Applying Microsoft Windows KB3050265 Update

 

The solution applies to the following environment:

  • GFI LanGuard 2015

  • Microsoft Windows 7

  • Microsoft Windows Server 2008R2 

 

  1. On the machine with the scan load, apply the Microsoft Windows KB3050265 update.

  2. From the GFI LanGuard Dashboard, right-click the device and go to Patch Management > Re-run Vulnerability Scan.

 

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  1. Priyanka Bhotika

  2. Posted

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