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FaxMaker | FaxMaker Not Receiving Faxes Via Email

Summary

Customer is not receiving faxes from FaxMaker via email despite Test email working properly.

Overview

  • FaxMaker receives faxes
  • FaxMaker not receiving faxes via email
  • Test email works properly.  
  • We see the following in the notifications.gfi_log
2018-06-22,11:01:57,446,1,"#0000278c","#00001684","info ","notifications","CNotification::Init::Start not_report for " 
2018-06-22,11:01:57,446,1,"#0000278c","#00001684","info ","notifications","CNotification::Init::Template to use: data\reports\fax_recv_success.fbt" 
2018-06-22,11:01:57,446,1,"#0000278c","#00001684","info ","notifications","CNotification::PrepareNotification." 
2018-06-22,11:01:57,446,1,"#0000278c","#00001684","info ","notifications","CNotification::PrepareNotification - Template Exists" 
2018-06-22,11:01:57,446,1,"#0000278c","#00001684","info ","notifications","CNotification::ReplacesBodyTags:: Starting Replacing Tags" 
2018-06-22,11:01:57,447,1,"#0000278c","#00001684","error ","notifications","CNotification::ReplacesBodyTags:: failed to create destination file, err[3]" 
2018-06-22,11:01:57,447,1,"#0000278c","#00001684","error ","notifications","Notification::PrepareNotification:: Error replacing tags." 
2018-06-22,11:01:57,447,1,"#0000278c","#00001684","info ","notifications","DeleteNotification:: [0x178F4050]" 
2018-06-22,11:01:57,447,1,"#0000278c","#00001684","info ","notifications","CNotification::DeleteAttachmentsPagesFiles" 
2018-06-22,11:01:57,447,1,"#0000278c","#00001684","info ","notifications","CNotification::Uninit::Finished not_report"

Cause

  • This has been known to happen when FaxMaker has been installed on another server, not in the default location or has been moved.  
Within this path in the registry
OR
In the ProductRegistry log within the root of the support folder
  • Ensure these paths point to the currently installed location.
HKEY_LOCAL_MACHINE\SOFTWARE\GFI Fax & Voice\FAXmaker\Config\E2FG

Example

Current Installation path:  
C:\Program Files (x86)\GFI\FaxMaker

Registry settings/paths:
[HKEY_LOCAL_MACHINE\SOFTWARE\GFI Fax & Voice\FAXmaker\Config\E2FG] 
indir = D:\Program Files (x86)\GFI\FaxMaker\in 
outdir = D:\Program Files (x86)\GFI\FaxMaker\out 
basedir = D:\Program Files (x86)\GFI\FaxMaker\client\mailbox 
  • These paths do not match the installation path and when the faxserver service tries to write the file, it is attempting to write to a path that does not exist.

 

Resolution

  • Change the Registry paths to match the installation path.

In our example

Current installation path:  
C:\Program Files (x86)\GFI\FaxMaker

Registry settings/paths:
[HKEY_LOCAL_MACHINE\SOFTWARE\GFI Fax & Voice\FAXmaker\Config\E2FG] 
indir = D:\Program Files (x86)\GFI\FaxMaker\in 
outdir = D:\Program Files (x86)\GFI\FaxMaker\out 
basedir = D:\Program Files (x86)\GFI\FaxMaker\client\mailbox 
  • The registry paths would change from what is listed above to what is listed below:
Registry settings/paths:
[HKEY_LOCAL_MACHINE\SOFTWARE\GFI Fax & Voice\FAXmaker\Config\E2FG] 
indir = C:\Program Files (x86)\GFI\FaxMaker\in 
outdir = C:\Program Files (x86)\GFI\FaxMaker\out 
basedir = C:\Program Files (x86)\GFI\FaxMaker\client\mailbox 

Result

  • This will now allow the faxserver service to write the notification to a valid directory location.
Choose files or drag and drop files
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  1. Priyanka Bhotika

  2. Posted

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