Overview
This article describes the resolution of an issue which occurs when the GFI FaxMaker Client form does not open when a document is printed on the GFI FaxMaker printer.
Environment
- GFI FaxMaker
- All supported environments
Root Cause
The issue occurs when the fmstart.exe process does not have permissions to run successfully.
fmstart.exe is a background process which runs in the context of the logged-on user. The process needs access to certain registry keys in order to function properly.
Resolution
To resolve the issue, follow the steps mentioned below:
- Open Task Manager and click Show processes from all users.
- Verify whether one instance of fmstart.exe is running under the sending user's account.
- If fmstart.exe is not running under the sending user's account, you can manually start the process from the GFI FaxMaker client install directory.
- Navigate to the default path of GFI FaxMaker installation root:
C:\Program Files\GFI\FaxMaker Client
(For 64 bit, the installation directory isC:\Program Files (x86)\GFI\FaxMaker Client
)
- To ensure that fmstart.exe starts after the server/machine reboots, add it as a startup task.
Additional Steps
- Start regedit.exe with administrative permissions.
- Navigate to the following registry paths depending on your platform:
- x86 bit:
HKEY_LOCAL_MACHINE\Software\GFI Fax & Voice
- x64 bit:
HKEY_LOCAL_MACHINE\Software\Wow6432Node\GFI Fax & Voice
- x86 bit:
- Right-click GFI Fax & Voice and select Permissions...
- Ensure that Everyone is listed with Full Control permissions.
- Select Advanced.
- Select Replace permission entries on all child objects with entries shown here that apply to child objects.
- Apply the permissions.
If the issue persists, install or re-create the FaxMaker printer.
Priyanka Bhotika
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