Overview
In an environment where the Exinda units are using WAN Memory for acceleration, an error may occur which causes crashes for the WAN Memory service.
Example log entry from Configuration > System > Logging (where XXXXXXXXXXX is an Exinda appliance's host ID) :
Jun 10 11:30:45 exinda1 pm[3276]: [pm.NOTICE]: Output from wmd (pid 1899): what(): Segment not found: hash:007FBA0B019A09B in:COMP remote-hostid:XXXXXXXXXXX {process_msg_comp@codec/Decoder.cpp:754}
This article provides a resolution for this error.
Root Cause
This error happens when one device attempts to send a missing/corrupt hash to a second device. This will cause the second device's WMD (WAN Memory) process to crash.
Resolution
It is possible that the hash causing the error has been transmitted to other devices as well, so it would be a good precautionary measure to perform the steps given below. This might also cause high memory paging on the Exinda. The resolution is the same as below.
To prevent the crash from happening from that one single device attempting to send a missing hash, first find out which unit is causing the error. As shown in the error message above, the host ID will identify the problem unit. You can find the list of hosts and their IP addresses in Configuration > System > Optimization > Community in the Community Peers section.
From the device with the host ID causing the error, log into the Web UI and perform the following steps:
- Navigate to Configuration > System > Optimization.
- On the Services tab, stop the WAN Memory service.
- Switch to the WAN Memory tab, and press the Reset button beside Reset Persistent Data.
- Also, press the Expire button beside Force Data Expiration.
- Go back to the Services tab and start the WAN Memory service
If this is a clustered setup, hard code the speed and duplex settings on the cluster interfaces.
Priyanka Bhotika
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