Overview
You might experience the following Server error when accessing Kerio Connect Webmail.
Failed to read rights from folder INBOX, internal error.
This article provides information on the root cause of this issue and how to resolve it.
Prerequisites
Admin (root) access to Kerio Connect server
Root Cause
The cause of this issue is the corruption of Operating System (OS) level folder rights (occupied by another OS process), which prevents Kerio Connect to access the internal structure files, like the FLD and DBO files.
Process
- Stop Kerio Connect.
Refer to this article on Starting or Stopping the Kerio Connect Server. - Navigate to the Kerio Connect store folder.
Please see below the default store folders for different operating systems.
- Windows:
C:\Program Files\Kerio\MailServer\Store\Mail\[domain][username]\
- macOS:
/usr/local/kerio/mailserver/store/mail/[domain]/[username]
- Linux:
/opt/kerio/mailserver/store/mail/[domain]/[username]
- Windows:
- Rename the INBOX folder to
INBOX2
. - Start Kerio Connect.
Refer to this article on Starting or Stopping the Kerio Connect Server. - Open the affected Webmail.
- Check if the INBOX folder is empty.
- Log out from Webmail.
- Move (cut and paste) all the EML files from
INBOX2/#msgs
toINBOX/#msgs
.
- Log in to Webadmin.
Please refer to this article on Accessing the Kerio Connect Administration Console. - Re-index the affected user mailbox.
Please refer to this article on Fixing Data Consistency Issues. - Log in to Webmail and check if the emails are in the INBOX folder.
- Remove the INBOX2 folder.
Confirmation
You are able to access the Webmail INBOX folder without any issues.
Related Article
Re-Indexing Corrupted User Folders Manually
Priyanka Bhotika
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