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Forward to email action turns spam into .bad file in Replay folder

Answer

PROBLEM

When a blocked spam email is forwarded to the specified email address, it turns into a .bad file and stays in the Replay/Pickup folder.
 
The QAS.ForwardMail log file will show the following line:
 
"error ","QAS.ForwardMail","Error HRESULT E_FAIL has been returned from a call to a COM component." 

ENVIRONMENT

  • GFI MailEssentials 
  • All supported environments

SOLUTION

  1. Re-register the OLE DLL's with the following commands:
    • regsvr32 "C:\Windows\System32\ole32.dll"
    • regsvr32 "C:\Windows\System32\oleaut32.dll"
  2. If that does not work, replace the ticket manager database file ticketmgr.mdb from a clean install. Support can provide one of these if one is not available.
  3. Place the file in the MailEssentials\Data folder and restart the GFI MailEssentials services. 

CAUSE

Missing or corrupt ticket manager database.
Choose files or drag and drop files
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  1. Priyanka Bhotika

  2. Posted

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