Overview
This article outlines two different methods to rebuild an Archive Store Index.
Diagnosis
Users may notice their search is failing to provide information for a selected time period, but they can browse to the message manually within the Archiver Console > Archive tab. This is an indication that there may be corruption within the Search index.
Alternatively, an administrator may be viewing the Archive Stores under Configuration > Archive Stores and find that the Index State is listed as invalid.
Solution
Notes:
- Indexing can be a lengthy process and adds additional load to the system
- Depending on the number of items in an archive store, the items themselves and system performance, rebuilding an index can take anything from a few minutes to multiple days or even weeks
- It is not recommended to rebuild all indexes for all archive stores at the same time - it is often better to rebuild them one by one
Method 1 - Via Archive Stores
Using this method will keep the old index on disk while a new index is being built aside of the old one. Once the building of the new index is complete, the old index will be deleted.
Assuming the old index is still in a healthy state, the old index can be utilized for search queries while the new one is being built when using this method.
- Open the GFI Archiver web page.
- Navigate to Configuration > Archive Stores.
- Select the desired archive store.
- Click on Rebuild Index
Method 2 - Forced Rebuild
Using this method will remove the old index, then build a new one from scratch.
- Open the GFI Archiver web page.
- Navigate to Configuration > Archive Stores.
- Select the desired archive store.
- Click on Summary.
- Take a note of the Path to search index.
- Launch services.msc (Alternatively select Start > Programs > Windows Administrative Tools > Services)
- Stop the GFI Archiver Search service.
- Delete the Index Folder of the desired archive store from disk (the folder from step 5)
- Start the GFI Archiver Search service.
- GFI Archiver will detect that no index exists for the archive store and start to build a new one
Testing
We can confirm the Index rebuild is ongoing by navigating to the Archiver Console > Configuration > Archive Stores and checking the Index status of the Archive Store. Specifically we will be looking for one of the three following states.
Pending | This is the state used before an index is going to start rebuilding. The search index will remain in Pending state if there are other indexes being rebuilt at that point in time. | |
Rebuilding | Rebuilding indicates that the Search service is indexing a whole database. The search index would change to this state should you click Rebuild Index within the GFI Archiver Configuration. The size of the database being indexed affects the duration of the rebuilding of the index. | |
Rebuilding Paused | The rebuilding index process is manually paused within the GFI Archiver Configuration. The index will remain in this state until Continue Indexing is clicked. |
When the Index rebuild is completed and the status goes back to Online , perform a search from the Archive tab of the console, and confirm mail from the time frame re-indexed is able to be found again.
Priyanka Bhotika
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