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Making Special Characters Searchable

Overview

This article describes the issue when you are searching for text which contains special characters ($ or #) and emails containing these characters are not returned by search queries.

Example 1:
An email contains the text: AB&C
When searching for "AB&C" the email is not found.

Example 2:
An email contains the text: Ticket# ABC-123456
When searching for "Ticket# ABC-123456" the email is not found.

 

Environment

  • GFI Archiver
  • All supported environment

 

Root Cause

The mentioned characters have a special meaning within the search engine. Searching for text containing such characters is not possible by default.

 

Resolution

Note: This procedure requires to edit files manually. If edited incorrectly it can leave the server in a non-operational state. Please keep backups of any file which is edited throughout this article before saving any changes to them.

  1. Open the web interface and navigate to Configuration > Archive Stores.
  2. Pause indexing for all indexes.
  3. For GFI Archiver 2015 SR1 build 20150218 or newer:
    1. Open the web interface.
    2. Navigate to: Configuration > Archive Stores > Index Management.
    3. Ensure that the following setting is enabled: Enable built-in word breaker (recommended).

    For GFI Archiver 2015 build 20141111 or older:

    1. Open the folder ..\InstallationFolder\Search\Viewers\
    2. Rename the existing file WordBrkShim.dll to WordBrkShim.dll-inactive.
      If renaming the file fails, stop the GFI Archiver Search service and try again.

  4. Open the folder ..\InstallationFolder\Search\Data\ 
  5. Open the following file in Notepad: product.config
  6. Add the following keys within the <appSettings> section to the file:
    <add key="AlphabetFile" value="alphabet.abc"/>
    <add key="SynonymChar" value="$"/>
  7. Save the file.
  8. Download the alphabet.abc zipped folder.
  9. Open the properties of the downloaded ZIP file and click the Unblock button if it is shown.
  10. Extract the file named alphabet.abc from the downloaded ZIP file into the folder: ..\InstallationFolder\Search\
  11. Stop all GFI Archiver services.
  12. Start all GFI Archiver services.

 

Validation

  1. Open the web interface and navigate to Configuration > Archive Stores
  2. Select one test archive store and rebuild its index.
  3. Wait until the rebuild is complete.
  4. Run test search queries against this rebuilt index to verify the results.
  5. Once you have verified that it is returning emails with the special characters, rebuild the other indexes too (preferably one by one).

Note: When upgrading to a newer version of GFI Archiver, installation files mentioned in this procedure will be overwritten with default versions making the changes void and ineffective. It is therefore suggested to keep a record of this procedure and follow it once again directly after upgrading to keep this functionality intact.

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  1. Priyanka Bhotika

  2. Posted

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