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Error: "Corrupted Indices (duplicates) Settings." When Indexing Does Not Start in Certain Archive Stores

Overview

"Corrupted Indices (duplicates) Settings."

When indexing does not start in certain archive stores, and both immediate and scheduled index rebuilding does not start (nor do their processes), you can find the above error under Home > Status Overview > Services > Configuration.

 

Prerequisites

 

Access to the GFI Archiver installation folder or logs containing MarcSettings.xml

 

Diagnosis

 

The GFI Archiver configuration has duplicate settings in regards to the same GUID number. All entries need to be unique.

To identify this issue, follow the steps below:

  1. Open ..\InstallationFolder\Core\Data\MArcSettings.xml in an editor (e.g., XML Marker).
  2. Check the IndexData elements in Search > Indexes, and identify multiple entries with the same GUID.
  3. Check the DatabaseID elements in Store > Databases, and see if duplicates exist.

The same GUID should be present in precisely one Store Database element and in one Search IndexData element. 

Below are examples of the relevant lines to look for in the MarcSettings.xml:

<Store> Section

<Database DatabaseType="MsSql" MetaEngine="None" MessageType="Eml" Guid="9890ce5c-9d2d-44b9-97c3-6da55edefdb0"
Visible="true" ReadOnly="false" Retention="false">
<DatabaseName>09 Archive</DatabaseName>

<Search> Section

<IndexData DatabaseId="9890ce5c-9d2d-44b9-97c3-6da55edefdb0" Active="true">
<RootPath>E:\Indexes\09 Archive\index</RootPath>
</IndexData>
<IndexData DatabaseId="9890ce5c-9d2d-44b9-97c3-6da55edefdb0" Active="true">
<RootPath>E:\Indexes\10 Archive\index</RootPath>
</IndexData>

 

Solution

 

Based on the example above, after locating the duplicate entry, remove one of the duplicate IndexData elements and save the file. After making the changes restart the services using the steps below.

  • Open the Services Console (services.msc)
    services.png
  • Locate the GFI Archiver Core service and restart it

 

Testing

 

After performing the above solution you should be able to start indexing Archive Stores again. Along with that the error message "Corrupted Indices (duplicates) Settings." on the Archiver console home page should no longer be showing as the duplicates indices have been removed. 

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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