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Users no longer have access to the mailboxes of other users

Answer

PROBLEM

Users cannot access other users mailboxes anymore, although necessary entries had been made in the past under Configuration > Access Control.

One or more entries under Configuration > Access Control contain GUID like entries. For example: [6fd8bd7a5cb1724580e80aaa3436e94b] (deleted)
 
The debug log ..\Core\Debuglogs\AdaEngineADDSHostplugin2.log or DirectoryEngineAD.log shows logging as below referring to the very same GUID number as the one showing:
 
"IsUserInGroup[8ef97447a9fc324d9f1ca7ff15e665e9][6fd8bd7a5cb1724580e80aaa3436e94b]: >>" 
"ERROR: IsUserInGroup: exception while enumerating user groups[There is no such object on the server.;]" 

ENVIRONMENT

  • GFI Archiver
  • All supported environments

SOLUTION

  1. Open the web page
  2. Navigate to Configuration > Access Control
  3. Remove any entries which are displayed as [GUID] (deleted) within a column that refers to groups, for example: [6fd8bd7a5cb1724580e80aaa3436e94b] (deleted)
  4. Re-add any Access Control entries as desired (create new groups in Active Directory if need be)

CAUSE

Groups which had been configured under Configuration > Access Control have been deleted from the Active Directory.
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  1. Priyanka Bhotika

  2. Posted

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