Overview
This article describes the issue and its resolution, which occurs when using the GFI Archiver Outlook Connector and Microsoft Outlook fails to open with the error:
Microsoft Office Outlook has stopped working
Fault Module Name: martoolbarx.dll
Debug logs show:
"error ","logfirebirdbackend","DatabaseBackend::UpgradeDatabase::Upgrade - failed to upgrade version, error description *** IBPP::SQLException ***
Unsuccessful execution caused by a system error that precludes
I/O error for file "C:\Users\userA\AppData\Local\GFI\MAILAR~1\7151BE7ECD616ABA-4A142277ADE9A1B4.FDB"
"error ","logfirebirdbackend","DatabaseConnectionHelper::AddDatabaseConnection Exception caught - *** IBPP::SQLException ***
Unsuccessful execution caused by a system error that precludes
"info ","logfirebirdbackend","DatabaseBackend::Folder::Load - failed to get folder, error description *** IBPP::SQLException ***
Unsuccessful execution caused by a system error that precludes
I/O error for file "C:\Users\userA\AppData\Local\GFI\MAILAR~1\28F2143DC3FECBB4-4A829EAC56ADC6C4.FDB"
"error ","logfirebirdbackend","DatabaseBackend::UpgradeDatabase::Upgrade
Environment
- GFI Archiver
- GFI Archiver Outlook Connector
Root Cause
The FDB file of the Outlook Connector is corrupt.
Resolution
- Ensure that Microsoft Outlook is closed.
- Delete the FDB which are referenced in the debug log error. For example, C:\Users\userA\AppData\Local\GFI\MAILAR~1\28F2143DC3FECBB4-4A829EAC56ADC6C4.FDB
- Start Microsoft Outlook and let the Outlook Connector resynchronize the GFI Archiver Mailbox.
Priyanka Bhotika
Comments